Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158866 - Small display typo
Summary: Small display typo
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
: 170356 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-26 13:19 UTC by Charles Lopes
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-20 13:45:56 UTC


Attachments (Terms of Use)

Description Charles Lopes 2005-05-26 13:19:51 UTC
Looks like there's an extra "echo" line in the nfs startup script. It says
"Shutting down NFS mountd:" when requesting the status.

# /etc/init.d/nfs status
rpc.svcgssd (pid 2989) is running...
Shutting down NFS mountd: rpc.mountd (pid 3337) is running...
nfsd (pid 3331 3330 3329 3328 3327 3326 3325 3324) is running...
rpc.rquotad (pid 3320) is running...

Comment 1 Dimitri Papadopoulos 2005-06-15 13:43:05 UTC
Yes, it's still there in FC4 final.


Comment 2 Dimitri Papadopoulos 2005-06-15 13:51:45 UTC
The relevant echo command from /etc/rc.d/init.d/nfs needs to be removed:

  status)
	[ -x /usr/sbin/rpc.svcgssd ] && /sbin/service rpcsvcgssd status
	echo -n $"Shutting down NFS mountd: "
	status rpc.mountd
	status nfsd
	if [ -n "$RQUOTAD" -a "$RQUOTAD" != "no" ]; then
		status rpc.rquotad
	fi
	;;


Comment 3 Dimitri Papadopoulos 2005-06-20 13:11:23 UTC
There's a second error in the 'nfs' script. Since it's the same script, I
thought I wouldn't open a new issue.

There are two '[  OK  ]' instead of one after 'Starting NFS mountd':

# /etc/init.d/nfs stop
Shutting down NFS mountd:                                  [  OK  ]
Shutting down NFS daemon:                                  [  OK  ]
Shutting down NFS quotas:                                  [  OK  ]
Shutting down NFS services:                                [  OK  ]
# 
# /etc/init.d/nfs start
Starting NFS services:                                     [  OK  ]
Starting NFS quotas:                                       [  OK  ]
Starting NFS daemon:                                       [  OK  ]
Starting NFS mountd:                                       [  OK  ]
#                                                          [  OK  ]

This is because 'nfs start' runs:
	/sbin/service rpcidmapd condstart
which produces an '[  OK  ]' just after:
	daemon rpc.mountd $RPCMOUNTDOPTS
which also produces an '[  OK  ]'.


Comment 4 Dan Tucny 2005-10-10 22:53:33 UTC
*** Bug 170356 has been marked as a duplicate of this bug. ***

Comment 5 Steve Dickson 2006-03-20 13:45:56 UTC
Fixed nfs-utils-1.0.7-13.FC4 and in nfs-utils-1.0.8.rc2-5.FC5



Note You need to log in before you can comment on or make changes to this bug.