Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158855 - Firewire ohci1394 crash during boot with connected disk
Summary: Firewire ohci1394 crash during boot with connected disk
Keywords:
Status: CLOSED DUPLICATE of bug 158854
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-26 07:26 UTC by Jan Kratochvil
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-26 07:28:47 UTC


Attachments (Terms of Use)

Description Jan Kratochvil 2005-05-26 07:26:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050420 Galeon/1.3.20 (Debian package 1.3.20-1)

Description of problem:
During inserted (I was not there) Firewire disk the Linux kernel crashes while booting.


Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1315_FC4

How reproducible:
Didn't try

Steps to Reproduce:
1. Connect FireWire disk.
2. Boot Fedora Core.


Actual Results:  Badness in get_phy_reg at drivers/ieee1394/ohci1394.c:238 (Not tainted)
 [<f8ad1288>] get_phy_reg+0x288/0x28d [ohci1394]
 [freed_request+22/102] freed_request+0x16/0x66
 [<c02902e6>] freed_request+0x16/0x66
 [__blk_put_request+90/116] __blk_put_request+0x5a/0x74
 [<c0291044>] __blk_put_request+0x5a/0x74
 [<f8ad2892>] ohci_devctl+0x618/0xaf6 [ohci1394]
 [common_interrupt+26/32] common_interrupt+0x1a/0x20
 [<c0103c0e>] common_interrupt+0x1a/0x20
 [delay_pmtmr+11/19] delay_pmtmr+0xb/0x13
 [<c011282b>] delay_pmtmr+0xb/0x13
 [<f8ad49d6>] ohci_irq_handler+0x655/0xce2 [ohci1394]
 [acpi_ev_gpe_detect+200/211] acpi_ev_gpe_detect+0xc8/0xd3
 [<c02357b7>] acpi_ev_gpe_detect+0xc8/0xd3
 [handle_IRQ_event+46/90] handle_IRQ_event+0x2e/0x5a
 [<c01506ed>] handle_IRQ_event+0x2e/0x5a
 [__do_IRQ+179/871] __do_IRQ+0xb3/0x367
 [<c01507cc>] __do_IRQ+0xb3/0x367
 [do_IRQ+74/130] do_IRQ+0x4a/0x82
 [<c0105b1d>] do_IRQ+0x4a/0x82
 =======================


Expected Results:  Booted Fedora Core.


Additional info:

I do not know more information from this accident. Take it or let it be.

Comment 1 Jan Kratochvil 2005-05-26 07:28:47 UTC

*** This bug has been marked as a duplicate of 158854 ***


Note You need to log in before you can comment on or make changes to this bug.