Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158802 - service smb start fails to start smbd
Summary: service smb start fails to start smbd
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-25 20:50 UTC by Stéphane Moinard
Modified: 2014-08-31 23:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-26 14:09:47 UTC


Attachments (Terms of Use)

Description Stéphane Moinard 2005-05-25 20:50:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Hello,

Under FC4-Test3, the script smb fails to start smbd (there is no problem with nmbd).

the error is : /etc/init.d/functions: line 83: 29607 Abort          $nice $*

If i try to start /usr/sbin/smbd -D manually, it works.

If i try to start "/usr/sbin/smbd -D" into another script than /etc/rc.d/init.d/smb, it fails (just a message that it is aborted).

Any idea ?

Thanks.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. service smb start fails only on the startup of smbd
2. under the shell, /usr/sbin/smbd -D works


Additional info:

Comment 1 Jay Fenlason 2005-05-25 21:02:03 UTC
WORKSFORME on my rawhide box, and I haven't changed anything in that area of 
the code in a long time.  Can you attach your /etc/samba/smb.conf to this bug 
so I can try to reproduce it? 
 
What does "strace -f -o <some log file> /sbin/service smb start" put in that 
log file.  It's going to be large, and the interesting part is probably at the 
end. 

Comment 2 Stéphane Moinard 2005-05-26 14:09:47 UTC
Hi Jey,

I found a solution. As i had the same problem to start dovecot, i searched 
thought that the problem was not involving samba.

Selinux was activated with "enforcing" policy. Desactivating selinux solved 
the problem.

I'm still interested to have a solution with selinux activated.

Best regards.


Note You need to log in before you can comment on or make changes to this bug.