Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1588 - Kern3l 2.2 Frame Buffering vs. Netscape
Summary: Kern3l 2.2 Frame Buffering vs. Netscape
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 5.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL: bob.houghton@hssltd.com
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-17 21:14 UTC by Bob Houghton
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-08 16:30:00 UTC


Attachments (Terms of Use)

Description Bob Houghton 1999-03-17 21:14:44 UTC
I upgraded a 5.2 RedHat install to the new 2.2 Kernel.  I
enabled frame buffering for a S3 Trio 3d (86C366) video
chip.  Everything works wonderful.  The kernel is fast, and
X-Windows rocks when run through this new feature.
Unfortunately, there is a bug.

When I run netscape, then run a Java applet, Netscape
crashes.  I installed another video card and turned off
frame buffering, and it works, so I am pretty certain that
it is something to do with frame buffering and Netscape's
Java.

Comment 1 Bob Houghton 1999-04-14 00:32:59 UTC
Has anyone approached this problem?  It will sure to be a big issue
shortly.

Comment 2 Bob Houghton 1999-04-15 21:33:59 UTC
DKL, I have about 2500 installs that need this to work.  Have you
heard anything????

Comment 3 Bill Nottingham 1999-04-16 00:06:59 UTC
I haven't been able to duplicate it here. Is there a specific
web site you can point me to that causes it to die?

Comment 4 Bob Houghton 1999-04-16 16:16:59 UTC
I can get it to crash by selecting the Java console from the netscape
menu's. [Communicator->tools->Java Console]  I just upgraded to kernel
2.2.5, and I am using Communicator 4.5.  I used the instructions at
www.uno.edu/~adamico/banshee to setup for Frame Buffering, and the
instructions at
www.redhat.com/support/docs/rhl/kernel-2.2/kernel2.2-upgrade-5.html
for the kernel 2.2.5 install.  The machine I have been working with is
an IBM 300GL.  The video chipset is the S3 Trio 3D (86C366), which
explains why I am trying to do frame buffering, i.e., no suitable
X-Window drivers I know of.

Everything else seems to work flawlessly using frame buffer.  It seems
to only affect Java within netscape.  When I installed another video
card, and turned off frame buffering, it worked fine even with the
same kernel image.

I can not remember if I tried this on a different machine.  If you
like, I can give it a try on a different piece of hardware.

Comment 5 Bob Houghton 1999-04-21 22:16:59 UTC
I tried this on an Acer box with a different chip.  Running off of a
normal X-Window driver, it worked.  With Frame Buffering, everything
worked until Netscape called a Java function.

I've been told that Caldera has promised to find a solution for us.
I'll keep you updated.

Thanks -- Bob

Comment 6 Bill Nottingham 1999-04-21 23:34:59 UTC
How many bpp are you running at?
Also, are you running XF86_Xvfb on top of the frame
buffer, or with a standard server?

Comment 7 Bob Houghton 1999-04-22 15:55:59 UTC
I am running something called XF68_FBDev I downloaded from
www.uno.edu/~adamico/banshee.  I am using "VGA=791" in my lilo prompt,
which is indicated in www.uno.edu/~adamico/banshee/files/vesafb.txt to
be 65,536 colors at 1024x768.  Do me a favor, and send me a copy of
your driver and XF86Config file, for it might be wise to rule out
problems with the code I am using.  Also, what version of Netscape are
you using?  I am using version 4.5 downloaded from the Netscape web
site for the 2.0 kernel; there is none for the 2.2 kernel.

Comment 8 Bill Nottingham 1999-04-22 19:15:59 UTC
What I've been testing on is the following:
kernel-2.2.5
Matrox Millenium using matroxfb
XF86_FBDev  from the 3.3.3.1 release
Netscape 4.51 (glibc-2.0 version)

Are you using the glibc or libc5 version of Netscape?
(Running ldd on it will tell you; if a libc.so.5 shows
up at all, it's the libc5 version.)

Comment 9 Bill Nottingham 1999-04-22 21:24:59 UTC
Also, are you running with a font server or with a local
font path? If so, what is the font path set to?


Note You need to log in before you can comment on or make changes to this bug.