Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158786 - Duplicate "GNAT User Guide" info item?
Summary: Duplicate "GNAT User Guide" info item?
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc4
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-25 18:51 UTC by Horst H. von Brand
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-31 09:38:32 UTC


Attachments (Terms of Use)

Description Horst H. von Brand 2005-05-25 18:51:00 UTC
Description of problem:
Updating my system today via yum I get:

  Updating  : gcc-gnat                     ##################### [ 35/112]
  install-info: menu item `GNAT User's Guide' already exists, for file `gnat_ug'

I seem to remember seeing something similar before, but didn't report.

Version-Release number of selected component (if applicable):
gcc-gnat-4.0.0-8

How reproducible:
Dunno

Steps to Reproduce:
1. Update gcc-gnat
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jakub Jelinek 2005-05-26 09:27:40 UTC
Was this an upgrade from FC3 (or earlier) or some (much older) FC4 test release?
There used to be a buggy gcc4 rpm or two many months ago, if you installed them,
the only fix was to manually edit /usr/share/info/dir.  But as that was not
in upgrade path from any rpm released as part of a stable distribution or update
thereof, it IMHO did not need ugly %post hacks.

Comment 2 Horst H. von Brand 2005-05-26 21:33:42 UTC
This was an upgrade from FC3 to FC4t2 and then (by tracking the development
branch + installing the fedora-release-3.92-1 package) FC4t3. Mostly updated
daily since FC4t2 + 1 week or so.

What shoukd I edit by hand, if that is the correct fix?

Comment 3 Jakub Jelinek 2005-05-30 15:35:50 UTC
Can you please post result of
grep gnat /usr/share/info/dir
?

Comment 4 Horst H. von Brand 2005-05-31 01:37:40 UTC
[vonbrand@laptop11 cogito]$ grep gnat /usr/share/info/dir
* gpgv: (gpgv).              signature verification tool
* GNAT Reference Manual: (gnat_rm).  Reference Manual for GNU Ada tools.
* GNAT User's Guide: (gnat_ug).  User's Guide for GNU Ada tools.
* gnat-style: (gnat-style).      GNAT Coding Style

Comment 5 Jakub Jelinek 2005-05-31 09:38:32 UTC
Either remove the
* GNAT User's Guide: (gnat_ug).  User's Guide for GNU Ada tools.
line and next gcc-gnat install will fix it up, or replace
(gnat_ug) with (gnat_ugn_unw).



Note You need to log in before you can comment on or make changes to this bug.