Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158784 - 2100S boot i20 raid error loading operating system
Summary: 2100S boot i20 raid error loading operating system
Keywords:
Status: CLOSED DUPLICATE of bug 159043
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: grub
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Peter Jones
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-25 17:54 UTC by Craig Gutshall
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-15 09:14:18 UTC


Attachments (Terms of Use)

Description Craig Gutshall 2005-05-25 17:54:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

Description of problem:
System with Adaptec 2100S RAID controller and SCSI hard drives attached.  Clean  install recognizes card and drives and installs completes normally.  However,  when the computer is rebooted after the installation the computer will stop with an "Error loading operating system".

Replicated with different 2100S cards, different BIOS levels (including latest) on the 2100S card.  Attempted with different make/model HD's and different motherboards (including IBM & Tyan).

If system is upgraded from RHAS 3 to RHAS 4 (on the same computer) failure does not occur.

Version-Release number of selected component (if applicable):
grub-0.95-3.1

How reproducible:
Always

Steps to Reproduce:
1. Create system with Adaptec 2100S RAID controller with two hd's in RAID1 config.
2. Install AS4 taking default hd config from install program.
3. Reboot
  

Actual Results:  System stops with "Error loading operating system" or similar message depending on motherboard.

Expected Results:  System should boot.

Additional info:

Comment 1 Jussi Silvennoinen 2005-05-31 11:56:37 UTC
You manually added block-driver i2o for Anaconda? It's not enough, grub-install
will fail. "Fixed" it by putting 'grub-install /dev/i20/hda' to my Kickstart
post-section.


Comment 2 Jussi Silvennoinen 2005-05-31 11:58:19 UTC
Uh, /dev/i2o/hda that is.


Comment 3 Warren Togami 2005-07-15 09:14:18 UTC

*** This bug has been marked as a duplicate of 159043 ***


Note You need to log in before you can comment on or make changes to this bug.