Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158783 - GIMP crashes
Summary: GIMP crashes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gimp
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-25 17:46 UTC by Tim Waugh
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: fc5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-14 06:33:28 UTC


Attachments (Terms of Use)
gdb backtrace (deleted)
2005-05-25 17:46 UTC, Tim Waugh
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 305206 None None None Never

Description Tim Waugh 2005-05-25 17:46:24 UTC
Description of problem:
GIMP can crash while using the file chooser.  It doesn't always happen,
unfortunately, but at least there is a core dump.

I'm reporting this against GIMP since that's where the symptoms occur, although
the crash happens in gtk2/glib2.

Version-Release number of selected component (if applicable):
gimp-2.2.7-4
glib2-2.6.4-1
gtk2-2.6.7-4
libgnomeui-2.10.0-1

How reproducible:
Once in a while.

Steps to Reproduce:
1. Open nautilus on a directory of JPEGs.
2. Start GIMP and load several of the JPEGs from that directory
3. Close some of the GIMP image windows
4. In nautilus, remove the corresponding JPEG files
5. In GIMP, File->Open that directory
  
Actual results:
Crash

Expected results:
Normal operation.

Additional info:
Here is a backtrace.  I'm afraid gdb isn't very helpful. :-(

Comment 1 Tim Waugh 2005-05-25 17:46:24 UTC
Created attachment 114846 [details]
gdb backtrace

Comment 6 Nils Philippsen 2005-05-27 13:54:42 UTC
I've found a bug upstream at the gnome bugzilla --
http://bugzilla.gnome.org/show_bug.cgi?id=305206 -- that my be related even
thought the backtrace looks different, if it is it may be a problem in
gnome-vfs2 rather than the gimp.

Given that gdb apparently can't quite handle the core file, can you please run
the gimp with "--stack-trace-mode always" from a terminal window and get a stack
trace from the running process when it crashes again? Additionally to the trace
above I'm interested in a "bt" trace as well, this way I can look at the call
trace more directly.

Comment 7 Nils Philippsen 2005-05-27 13:56:08 UTC
my -> may, call trace -> call stack

Comment 8 Nils Philippsen 2005-10-11 15:23:20 UTC
Can you reproduce the problem in current Rawhide?

Comment 9 Tim Waugh 2005-10-11 15:42:27 UTC
This is a really hard problem to isolate.  It has happened many times on FC4
since I reported it, but attempts to track down exactly what's going on have
failed.  I don't even have a how-to-reproduce for it. :-(

gimp-2.2.8-0.fc4.2 certainly still has the problem.

I am not yet in a position to try rawhide on the only machine that exhibits the
problem, I'm afraid.

Comment 10 Nils Philippsen 2006-04-07 10:51:21 UTC
Please report back once you get the chance to try this on FC5. Thanks!

Comment 12 Nils Philippsen 2006-06-14 06:37:55 UTC
DB lost this:

------- Additional Comments from Tim Waugh
Tried yesterday -- FC5 works fine!




Note You need to log in before you can comment on or make changes to this bug.