Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158781 - ppc64: Kernel Panic on I2C Bus in New Apple G5 Logic Board < 2.6.12
Summary: ppc64: Kernel Panic on I2C Bus in New Apple G5 Logic Board < 2.6.12
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-25 17:42 UTC by Daniel Shay
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-04 05:37:23 UTC


Attachments (Terms of Use)

Description Daniel Shay 2005-05-25 17:42:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Kernel problems related to the newest revision of the Apple G5 Dual Processor Systems.

Reference:

http://www.kernel.org/pub/linux/kernel/v2.6/testing/ChangeLog-2.6.12-rc5

Benjamin Herrenschmidt <benh@kernel.crashing.org>:
    [PATCH] ppc64: Fix booting on latest G5 models

    The latest speedbumped Apple G5 models have a "bug" in the Open Firmware
    device tree that lacks the proper interrupt routing information for the
    northbridge i2c controller.  Apple's driver silently falls back into a
    sub-optimal "polled" mode (heh, maybe they didn't even notice the bug
    because of that :), our driver didn't properly check and crashes :(

    This patch fixes our driver to not crash, and adds code to the
    prom_init() OF trampoline code that detects the "bug" and adds the
    missing information back for this chipset revision.  This fixes booting
    and thermal control on these models.

    Signed-off-by: Benjamin Herrenschmidt <benh@kernel.crashing.org>
    Signed-off-by: Linus Torvalds <torvalds@osdl.org>

Benjamin Herrenschmidt <benh@kernel.crashing.org>:
    [PATCH] ppc64: Fix g5 hw timebase sync

    The hardware sync of the timebase on SMP G5s uses a black magic
    incantation to the i2c clock chip that was inspired from what Darwin
    does.

    However, this was an earlier version of Darwin that was ...  buggy !
    heh.  This causes the latest models to break though when starting SMP,
    so it's worth fixing.

    Here's a new version of the incantation based on careful transcription
    of the said incantations as found in the latest version of apple's
    temple.

    Signed-off-by: Benjamin Herrenschmidt <benh@kernel.crashing.org>
    Signed-off-by: Linus Torvalds <torvalds@osdl.org>



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot any Linux PPC64 Kernel < 2.6.12
2.Kernel Panic After I2C Probe
 

Additional info:

Comment 1 Dave Jones 2005-05-27 00:34:25 UTC
The kernel in rawhide today should have this fixed, as it includes -rc5

Comment 2 Daniel Shay 2005-06-02 21:16:10 UTC
Installed and running 2.6.11-1.1366_FC4-ppc from the rawhide yesterday 06/01/2005.

Thanks


Note You need to log in before you can comment on or make changes to this bug.