Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158779 - vsftp log switches between time and utc time
Summary: vsftp log switches between time and utc time
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: vsftpd
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Radek Vokal
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 156322
TreeView+ depends on / blocked
 
Reported: 2005-05-25 17:32 UTC by Bret
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2005-552
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-05 14:30:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:552 qe-ready SHIPPED_LIVE vsftpd bug fix update 2005-10-05 04:00:00 UTC

Description Bret 2005-05-25 17:32:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Vsftpd logs time incorrectly, switching between the machine's local time and UTC time.

The configuration we use is locking users into their home directories (chroot_local_user), which may be the culprit.  I have included a snippet from a bug report to SUSE with similar behavior below.  

The time logs correctly until, for example, you create a directory.  If, for the next command then, you remove that same directory, the log entry shows up with the UTC time.



Here is an example:

Wed May 25 11:59:41 2005 [pid 9674] [tester] OK LOGIN: Client "127.0.0.1"

Wed May 25 12:01:24 2005 [pid 9676] [tester] OK MKDIR: Client "127.0.0.1", "/test1"

Wed May 25 17:02:15 2005 [pid 9676] [tester] OK RENAME: Client "127.0.0.1", "/test /test.txt"

Wed May 25 12:02:21 2005 [pid 9700] CONNECT: Client "128.104.212.189"



-----------------------------------------------------------------------------


From SUSE site:

URL:
http://66.218.71.225/search/cache?p=vsftpd+and+utc+and+log&toggle=1&ei=UTF-8&xargs=0&pstart=1&b=11&u=rpmfind.net/linux/SuSE-Linux/i386/update/9.2/patches/vsftpd-52022&w=vsftpd+utc+log&d=4F445936A9&icp=1&.intl=us


Longdescription.english:
Due to glibc changes the timezone info was reinitialized 
after vsftp did chroot, and thus was some log entries with 
UTC as timezone. This fix makes vsftpd use the correct 
timezone in the chroot environment.

Version-Release number of selected component (if applicable):
vsftpd-2.0.1-5vsftpd-2.0.1-5

How reproducible:
Always

Steps to Reproduce:
1. Our vsftpd.conf has anonymous_enable=NO,local_enable=YES,chroot_local=YES, etc...  I think that may be enough to reproduce this


2. FTP in using a local machine account.  Create a directory (mkdir test)

3. Then remove it, (rm test)

4.  Check the logs to see if the time discrepancy shows up
  

Additional info:

Comment 2 Radek Vokal 2005-06-01 10:46:35 UTC
Fixed in rawhide and added to propose list .. 

Comment 14 Red Hat Bugzilla 2005-10-05 14:30:40 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-552.html



Note You need to log in before you can comment on or make changes to this bug.