Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158743 - tar-1.14-err.patch causes SEGV
Summary: tar-1.14-err.patch causes SEGV
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tar
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-25 12:28 UTC by Mark Williams
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-26 13:18:22 UTC


Attachments (Terms of Use)

Description Mark Williams 2005-05-25 12:28:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705)

Description of problem:
Attempting to create a listed-incremental archive of a directory hierarchy containing a directory without read permission (and at least one other sibling file/ directory) causes a SEGV due to uninitialised memory while sorting.

Version-Release number of selected component (if applicable):
tar-1.14-4

How reproducible:
Always

Steps to Reproduce:
As a non-superuser:

% umask 077
% mkdir mydir
% mkdir mydir/noreaddir
% chmod u-r mydir/noreaddir
% touch mydir/file
% tar -cf mydir.tar -g mydir.listed mydir

Additional info:

This is caused by tar-1.14-err.patch---which AFAICT serves no useful purpose anyway (nor would it under later versions up to and including the current 1.15.1) because the function in question (scan_path) already handles the case of dirp being NULL (and then correctly terminates the obstack frame).

I suggest this patch be entirely removed.

Comment 1 Peter Vrabec 2005-07-21 15:54:43 UTC
I can not reproduce it. But when I look into code it seems to me you are right.


Comment 2 Peter Vrabec 2005-07-22 09:59:25 UTC
I got it. x86_64


Note You need to log in before you can comment on or make changes to this bug.