Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158734 - eclipse-ecj-3.1.0_fc-0.M7.5 breaks java-gcj-compat's tools.jar
Summary: eclipse-ecj-3.1.0_fc-0.M7.5 breaks java-gcj-compat's tools.jar
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-05-25 11:14 UTC by Gary Benson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-25 16:00:16 UTC


Attachments (Terms of Use)
Testcase (deleted)
2005-05-25 11:14 UTC, Gary Benson
no flags Details

Description Gary Benson 2005-05-25 11:14:51 UTC
Description of problem:
Changes to com.sun.tools.javac.Main in the latest java-1.4.2-gcj-compat break
ant's javac task.

Version-Release number of selected component (if applicable):
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_24rh
eclipse-ecj-3.1.0_fc-0.M7.5
libgcj-4.0.0-8

How reproducible:
Always

Steps to Reproduce:
1. javac -classpath /usr/lib/jvm/java/lib/tools.jar Test.java
2. java -classpath /usr/lib/jvm/java/lib/tools.jar:. Test
  
Actual results:
java.lang.ClassNotFoundException: org.eclipse.jdt.internal.compiler.batch.Main 

Expected results:
Nothing happens (it Just Works)

Comment 1 Gary Benson 2005-05-25 11:14:51 UTC
Created attachment 114820 [details]
Testcase

Comment 2 Gary Benson 2005-05-25 11:38:45 UTC
Ok, the problem is that /usr/share/java/jdtcore.jar was renamed as
org.eclipse.jdt.core_3.1.0.jar between eclipse-ecj-3.1.0_fc-0.M6.22 and M7.5. 
As an immediate fix I'm going to patch java-gcj-compat's tools.jar to use the
new path (Beehive will be broken until we do this) but for the long term we
should probably do something more robust: a filename like
org.eclipse.jdt.core_3.1.0.jar is obviously not something that's going to stay
the same over time.

How about having having the /usr/share/java symlink called eclipse-ecj.jar?
jdtcore.jar is fairly undescriptive for such a crucial file.

Comment 3 Andrew Overholt 2005-05-25 12:47:38 UTC
Sorry I didn't notice this change when we pushed in Eclipse 3.1M7. 
eclipse-ecj.jar sounds good to me; I'll make that change now.

Comment 4 Gary Benson 2005-05-25 13:28:12 UTC
java-1.4.2-gcj-compat-1.4.2.0-40jpp_25rh in dist-fc4-HEAD is pointing at
org.eclipse.jdt.core_3.1.0.jar, so ant in beehive will start working again when
someone moves that across to dist-fc4.  If you build a new eclipse for FC4 then
could you please make sure java-gcj-compat is updated and rebuilt too?  The bit
that needs changing is in java-gcj-compat-bz158734.patch for now.

Comment 5 Thomas Fitzsimmons 2005-05-25 16:00:16 UTC
This is fixed in java-1.4.2-gcj-compat-1.4.2.0-40jpp_26rh.


Comment 6 Gary Benson 2005-05-25 16:23:05 UTC
Woah, Andrew hasn't changed it in eclipse yet!

Comment 7 Thomas Fitzsimmons 2005-05-25 17:58:15 UTC
The updated eclipse is building right now.



Note You need to log in before you can comment on or make changes to this bug.