Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158720 - ipw2200 does not work anymore with 54Mb/s rate
Summary: ipw2200 does not work anymore with 54Mb/s rate
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-25 07:16 UTC by Ulrich Drepper
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-10 15:06:56 UTC


Attachments (Terms of Use)

Description Ulrich Drepper 2005-05-25 07:16:38 UTC
Description of problem:
With previous kernels (up to 2.6.11-1.1312) I used RATE=54M in my configu file
for the ipw2200 interface.  In the recent kernels (-1.133x and later) this
doesn't work anymore.  If I remove the line and let the kernel/card pick the
rate, the interface works.

Version-Release number of selected component (if applicable):
2.6.11-1.1341_FC4

How reproducible:
always

Steps to Reproduce:
1.start said kernel on machine with ipw2200 and RATE=54M in iface config
2.
3.
  
Actual results:
no network connection

Expected results:
working network

Additional info:

Comment 1 Ulrich Drepper 2005-05-26 08:02:30 UTC
Well, without the RATE parameter the card still automatically selects 54M as the
rate.  But I think it is still a regression that it doesn't work anymore if the
rate is explicitly specified.

Comment 2 Dave Jones 2005-05-27 00:11:17 UTC
I dropped back to the rev of the driver that was in FC3 for the final FC4
release as the updated one brought more problems than it fixed. I'll look at
doing an update again sometime after the release.


Comment 3 Ulrich Drepper 2005-05-28 04:55:54 UTC
I think this problem appears since with the old driver, any

iwconfig ethX rate xxx

call will simply fail while with the new one the driver actually does/tries to
do something.  We'll see when the driver gets reenabled.

Comment 4 Dave Jones 2005-10-06 07:21:43 UTC
now that this got merged upstream, we ended up with a different version of the
driver in rawhide. How is this behaving wrt to this bug ?


Comment 5 John W. Linville 2005-11-10 15:06:56 UTC
Closed due to lack of response.  Please reopen when the requested information 
becomes available...thanks! 


Note You need to log in before you can comment on or make changes to this bug.