Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158719 - ecj fails to compile subversion javahl on ppc64
Summary: ecj fails to compile subversion javahl on ppc64
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact:
URL:
Whiteboard:
Depends On: 172172
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-25 07:05 UTC by Joe Orton
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-12 23:29:46 UTC


Attachments (Terms of Use)

Description Joe Orton 2005-05-25 07:05:07 UTC
Description of problem:
javac on the bunch of .java files failed with:

Exception in thread "main" java.lang.NoClassDefFoundError:
org.eclipse.jdt.internal.compiler.batch.Main
   at 0x0000008000d6bad0 (Unknown Source)
   at 0x0000008000d69878 (Unknown Source)
   at 0x0000008000d68d64 (Unknown Source)
   at 0x0000008000d53220 (Unknown Source)
   at 0x0000008000d557f0 (Unknown Source)
   at 0x0000008000d57420 (Unknown Source)
   at 0x0000008000e05994 (Unknown Source)
   at 0x0000008000d3a9f4 (Unknown Source)
   at 0x0000008000cf085c (Unknown Source)
   at 0x000000800003c9f8 (Unknown Source)
   at 0x0000008001bde27c (Unknown Source)
   at 0x0000008001bde474 (Unknown Source)
Caused by: java.lang.ClassNotFoundException:
org.eclipse.jdt.internal.compiler.batch.Main not found in
gnu.gcj.runtime.SystemClassLoader{urls=[file:./],
parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
   at 0x0000008000d6bad0 (Unknown Source)
   at 0x0000008000d69878 (Unknown Source)
   at 0x0000008000d68d64 (Unknown Source)
   at 0x0000008000d68df0 (Unknown Source)
   at 0x0000008000d53310 (Unknown Source)
   at 0x0000008000d525a0 (Unknown Source)
   at 0x0000008000d525e4 (Unknown Source)
   at 0x0000008000edccfc (Unknown Source)
   at 0x0000008000d5136c (Unknown Source)
   at 0x0000008000d50df8 (Unknown Source)
   at 0x0000008000d30bac (Unknown Source)
   at 0x0000008000d2f674 (Unknown Source)
   at 0x0000008000e0591c (Unknown Source)
   ...5 more

ecj-3.1-0.M4.9 is in the buildroot currently.

Comment 4 Andrew Overholt 2005-05-25 16:27:48 UTC
We don't have Eclipse (and hence eclipse-ecj) on ppc64 yet.  If there's an old
ecj package on ppc64, it should probably be removed.

Comment 5 Gary Benson 2005-10-24 09:29:21 UTC
java-1.4.2-gcj-compat-devel bundles a recent eclipse-ecj jarfile on platforms
where eclipse is not yet built.  So you'll probably hit this bug when you start
porting eclipse to ppc64.

Comment 6 Andrew Overholt 2005-10-27 20:23:29 UTC
I (finally) added ia64 and ppc64 to the Eclipse build arches.  I'll see what
happens ...

Comment 7 Joe Orton 2005-12-12 19:20:55 UTC
The subversion javahl build appears to work on ppc64 in dist-fc5.  Should I
close this?

Comment 8 Andrew Overholt 2005-12-12 19:34:47 UTC
I can't see why not.  We should really verify that these work with the subclipse
eclipse plugin (the last time I tried, they didn't).


Note You need to log in before you can comment on or make changes to this bug.