Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158701 - process `sysctl' is using deprecated sysctl
Summary: process `sysctl' is using deprecated sysctl
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: procps
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-24 23:06 UTC by Doug Henderson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-19 07:17:38 UTC


Attachments (Terms of Use)

Description Doug Henderson 2005-05-24 23:06:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
After executing "yum --exclude=\*4.0.0-8\* update", rebooting, and "telinit 5", the following message appears in /var/log/messages:

May 24 16:38:32 lambda kernel: process `sysctl' is using deprecated sysctl (syscall) net.ipv6.neigh.eth0.base_reachable_time; Use net.ipv6.neigh.eth0.base_reachable_time_ms instead.



Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1341_FC4

How reproducible:
Didn't try

Steps to Reproduce:


Additional info:

Comment 1 Karel Zak 2005-05-25 09:03:23 UTC
It's wrong sysctl usage. It looks like problem with some initscript where is
deprecated sysctl option.

Can you check your /etc/sysctl.conf or you can try:

grep -r "net.ipv6.neigh.eth0.base_reachable_time" /etc/* 2> /dev/null



Comment 2 Doug Henderson 2005-05-25 12:27:07 UTC
[root@lambda ~]# more /etc/sysctl.conf 
# Kernel sysctl configuration file for Red Hat Linux
#
# For binary values, 0 is disabled, 1 is enabled.  See sysctl(8) and
# sysctl.conf(5) for more details.

# Controls IP packet forwarding
net.ipv4.ip_forward = 0

# Controls source route verification
net.ipv4.conf.default.rp_filter = 1

# Do not accept source routing
net.ipv4.conf.default.accept_source_route = 0

# Controls the System Request debugging functionality of the kernel
kernel.sysrq = 0

# Controls whether core dumps will append the PID to the core filename.
# Useful for debugging multi-threaded applications.
kernel.core_uses_pid = 1

# Controls the use of TCP syncookies
net.ipv4.tcp_syncookies = 1

# vvvv Oracle 10g
#kernel.shmall = 2097152
kernel.shmmax = 2147483648
#kernel.shmmni = 4096
kernel.sem = 250 32000 100 128
fs.file-max = 65536
net.ipv4.ip_local_port_range = 1024 65000
# ^^^^
[root@lambda ~]# grep -r "base_reachable_time" /etc/* 2> /dev/null
[root@lambda ~]#

Comment 3 Karel Zak 2005-10-12 12:58:43 UTC
Do you have still this problem with the latest kernel and procps?

Comment 4 Doug Henderson 2005-10-19 02:46:36 UTC
I haven't seen this message with FC4 or FC5 (Rawhide) in a long time.

Comment 5 Karel Zak 2005-10-19 07:17:38 UTC
Thanks for your feedback. Closing.


Note You need to log in before you can comment on or make changes to this bug.