Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158697 - rpm fails to catch package requirement, up2date fails
Summary: rpm fails to catch package requirement, up2date fails
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-24 22:15 UTC by John Howe
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-28 19:56:03 UTC


Attachments (Terms of Use)

Description John Howe 2005-05-24 22:15:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
We ship a product for RedHat Enterprise with several rpms. During testing, it was discovered that one of our rpms has a malformed requirement for mod_ssl.

# rpm -qpR n2h2-admin-ui-4.0-15.i386.rpm 
/bin/sh  
/bin/sh  
/opt/n2h2/lib/cgi-lib.pl  
/opt/n2h2/lib/check_url.pl  
/opt/n2h2/lib/errors.pl  
/usr/bin/perl  
mod_perl >= 1.26-2
mod_ssl >= 2.8.7-3
n2h2-logserver >= 1.6-2
n2h2-shared >= 2.5-1
n2h2-virtual-reviewer >= 1.0-14
perl(ActivityLog)  
perl(Apache::Log)  
perl(Apache::TicketTool)  
perl(Authen::SASL)  
perl(Authen::SASL::CRAM_MD5)  
perl(Authen::SASL::Perl::CRAM_MD5)  
perl(CGI)  
perl(Config::IniFiles)  
perl(DBI)  
perl(Digest::MD5)  
perl(File::Copy)  
perl(Getopt::Long)  
perl(HandleAdmins)  
perl(HandleCluster)  
perl(HandleIPs)  
perl(HandleLDAP)  
perl(IO::File)  
perl(IO::Socket)  
perl(LWP::Simple)  
perl(N2H2::Admin)  
perl(N2H2::ApacheHelper)  
perl(N2H2::LWCookie)  
perl(N2H2::StatusCodes)  
perl(N2H2Config)  
perl(Net::LDAP)  
perl(Net::LDAP::Control::Sort)  
perl(Net::LDAP::Util)  
perl(Net::SMTP)  
perl(constant)  
perl(lib)  
perl(mod_perl)  
perl(strict)  
perl(vars)  
perl(warnings)  
perl-Apache-DBI >= 0.91-1
perl-Authen-SASL >= 2.04-02
perl-Convert-ASN1 >= 0.16-1
perl-Digest-HMAC >= 1.01-1
perl-Digest-SHA1 >= 2.01-15
perl-IO-Socket-SSL >= 0.94-1
perl-N2H2-IFPAdmin >= 1.0-22
perl-N2H2-Redirect >= 1.1-4
perl-URI >= 1.12-5
perl-XML-Parser >= 2.30-7
perl-ldap >= 0.29
postgresql-server >= 7.1.3-2
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

Note that the mod_ssl requirement is for the RedHat 7.3 release tree. RH Enterprise 3 Update 5 ships with mod_ssl-2.0.46-46.ent.

When installed the n2h2-admin-ui rpm, it would be expected that the requirement for mod_ssl would fail as mod_ssl-2.0.46-46.ent is installed and the package requires mod_ssl >= 2.8.7-3.

Executing 'rpm -Uvh n2h2-admin-ui-4.0-15.i386.rpm' returns no errors.

Another test system had RedHat Enterprise 3.0 Update 4 installed and we attempted to up2date the system to Update 5. up2date returned an error:

Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
n2h2-admin-ui-4.0-8                      requires mod_ssl >= 2.8.7-3
n2h2-reports-1.0-20                      requires mod_ssl >= 2.8.4-9

What is strange is that 'rpm -Uvh' does not catch the mod_ssl requirement, however, up2date does.

This seems related to https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=115954

Version-Release number of selected component (if applicable):
rpm-4.2.3-21_nonptl

How reproducible:
Always

Steps to Reproduce:
1. Download SmartFilter DA product
2. Install product on RedHat Enterprise Update 4 baseline
3. Examine mod_ssl requirement of n2h2-admin-ui/n2h2-reports
   # rpm -q -R n2h2-admin-ui | grep mod_ssl
   mod_ssl >= 2.8.7-3
4. Examine installed mod_ssl
   # rpm -q mod_ssl
   mod_ssl-2.0.46-46.ent
5. Attempt to up2date system to RedHat Enterprise Update 5.
up2date fails with message:

Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
n2h2-admin-ui-4.0-8                      requires mod_ssl >= 2.8.7-3
n2h2-reports-1.0-20                      requires mod_ssl >= 2.8.4-9

  

Actual Results:  Installer completes without any errors on mod_ssl requirements. Up2date fails due to package dependency problems.

Expected Results:  Installer should have failed with rpm catching missing required packages. 
'rpm -Uvh package' should have failed since version does not meet requirements ( package >= version )

Additional info:

See related bug: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=115954

Comment 1 Paul Nasrat 2005-05-24 22:30:08 UTC
Note support requests for RHEL should be directed through
http://www.redhat.com/support/

rpm --provides -q mod_ssl
mod_ssl = 1:2.0.46-46.ent

RHEL 3 has mod_ssl epoch 1

with no epoch specified in the requires that is equivalent to epoch 0 so RHEL 3
mod_ssl beats that on epoch comparision.



Comment 2 Paul Nasrat 2005-11-28 19:56:03 UTC
Please correct your spec file.


Note You need to log in before you can comment on or make changes to this bug.