Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158696 - Anaconda/Disk Druid displays wrong size for LVM VG member in VG dialog.
Summary: Anaconda/Disk Druid displays wrong size for LVM VG member in VG dialog.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-24 22:00 UTC by Paul W. Frields
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-15 16:52:27 UTC


Attachments (Terms of Use)

Description Paul W. Frields 2005-05-24 22:00:09 UTC
Description of problem:

I noticed this problem while making screenshots for the upcoming Fedora
Installation Guide.  It is not a showstopper, but is misleading and possibly
confusing to users.  This seems to happen when a disk has pre-existing LVM
partitions.


Version-Release number of selected component (if applicable):
10.2.0.61-1


How reproducible:
Every time, AFAICT.


Steps to Reproduce:
1. Start with a disk with a pre-existing LVM setup.  My guest OS has a 40 GB
disk ("sda") available, that had a ~100 MB /boot partition (ext3), a ~3200 MB
LVM partition/PV, and a ~300 MB swap partition.
2. Boot FC4t3 anaconda and manually partition disk.
3. Remove existing partitions and create new ones:  ~100 MB fixed /boot (ext3,
sda1), ~40 GB LVM PV (sda2).
4. Select "LVM" button to enter "Make LVM Volume Group" dialog.
  

Actual results:
Size of VG member sda2 is displayed as 3200 MB, which is incorrect.


Expected results:
Size of sda2 should be ~40000 MB.


Additional info:
I am using VMware but would not expect different behavior from a "real" machine
(which I don't have available to test).  Because this is not a showstopper bug,
I wouldn't expect it to be fixed for FC4 final, but I will be happy to test the
bug with the final release on a "real" machine.  Unfortunately, I have none
available at present, but will in June.

Comment 1 Jeremy Katz 2005-05-25 15:32:59 UTC
Chris -- can you take a look at this?  If the fix is simple enough, it'd be good
to get into FC4 although it is late :/

Comment 2 Chris Lumens 2005-05-25 18:24:26 UTC
Committed a fix to head and fc4-branch.


Note You need to log in before you can comment on or make changes to this bug.