Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158654 - amarok fails to build on x86_64
Summary: amarok fails to build on x86_64
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: amarok
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE4Target
TreeView+ depends on / blocked
 
Reported: 2005-05-24 15:54 UTC by Jeremy Katz
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-02 23:50:53 UTC


Attachments (Terms of Use)

Description Jeremy Katz 2005-05-24 15:54:33 UTC
amarok fails to rebuild on x86_64.  It looks like it just needs to source the qt.sh
http://extras64.linux.duke.edu/failed/development/amarok/1.2.3-2.fc4/

Comment 1 Jeremy Katz 2005-05-25 23:47:43 UTC
That's done in the devel tree and now we just hit the kde compiler blacklisting.
 *sigh*

Comment 2 Aurelien Bompard 2005-05-28 15:38:01 UTC
I've looked at the KDE spec files in CVS and I've search the list archives, but
I can't find The Right Way to deal with this. I've seen that gcc4 in FC4 is
patched against the bug causing KDE to be miscompiled, but how should I deal
with the blacklisting itself now ? Should I just patch the configure script ?

Comment 3 Jeremy Katz 2005-05-28 22:32:18 UTC
Yeah, that's the way I'd do it.

Comment 4 Michael Schwendt 2005-06-02 10:56:45 UTC
x86_64:
checking for Qt... configure: error: Qt (>= Qt 3.2) (library qt-mt) not found. P
lease check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

i386:
grep: /usr/lib/libltdl.la: No such file or directory
/bin/sed: can't read /usr/lib/libltdl.la: No such file or directory
libtool: link: `/usr/lib/libltdl.la' is not a valid libtool archive

ppc:
ERROR: something went wrong rebuilding the .src.rpm


[...]

Comments:

x86_64: looks like $QTDIR problems, though I wonder why? (multilib installation
sourcing the i386 one?)

ppc: some dependency missing? Could not find a missing package on ppc in a brief
BR check?

i386: smells like the %fedora conditional BuildRequires on libtool-ltdl-devel
doesn't work.

=> giving 1.2.4-3.fc4 a try in the build system


Comment 5 Michael Schwendt 2005-06-02 17:36:16 UTC
Status update: Some unknown update in the extras buildsys now causes the build
to fail with lots of C++ errors, also on i386. One can see how it managed to
build a few hours ago:
http://extras64.linux.duke.edu/failed/4/amarok/1.2.4-3/i386/  The new problems
are probably related to gcc-4.0.0-9, since I cannot reproduce it with
gcc-4.0.0-8 and need to sync with Rawhide. Additionally, on ppc, the src.rpm
refused to build, again without no reason given. Filed that as 159414.

Comment 6 Michael Schwendt 2005-06-02 23:50:53 UTC
1.2.4-6 made it. No ppc src.rpm build problem fortunately.



Note You need to log in before you can comment on or make changes to this bug.