Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158620 - libgpm should not print messages to stderr
Summary: libgpm should not print messages to stderr
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gpm
Version: 4
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Petr Rockai
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-24 08:21 UTC by Cipriano Groenendal
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-19 10:03:22 UTC


Attachments (Terms of Use)

Description Cipriano Groenendal 2005-05-24 08:21:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
When starting MC several errors messages are printed behind the interface. Running mc 2> mc.log givs the following messages:

*** info [lib/liblow.c(329)]:
/dev/gpmctl: No such file or directory
*** err [lib/liblow.c(336)]:
/dev/gpmctl: No such file or directory

As this is a headless, text only server, no mouse has ever, or will ever be connected to it.


Version-Release number of selected component (if applicable):
mc-4.6.1-0.14.FC3

How reproducible:
Always

Steps to Reproduce:
1. run mc 2> mc.log
2. exit mc
3. cat mc.log
  

Additional info:

Comment 1 Jindrich Novy 2005-05-24 08:41:23 UTC
This doesn't seem like mc problem to me as there's no liblow.c in mc sources,
but in libgpm. Maybe something is broken with your local gpm installation.
Peter, do you have any clue? Maybe recreation of /dev/gpmclt is sufficient?

Comment 2 Cipriano Groenendal 2005-05-24 09:19:21 UTC
FYI:
# rpm -q gpm
gpm-1.20.1-66

Comment 3 Miloslav Trmač 2005-05-24 09:43:46 UTC
I've seen this too, I think it happens when gpm is not running.

Comment 4 Cipriano Groenendal 2005-05-24 10:12:22 UTC
mitr@redhat.com is correct. When the gpm service is running, these messages do 
not appear. Stopping the service and restarting mc will once again give the 
messages. Stopping the service from withing mc does the same.

Comment 5 Petr Rockai 2005-06-21 13:47:05 UTC
Releases < fc4 will not be changed, use mc --nomouse to get rid of the  
message. Gpm in >= fc4 shall be changed to not print spurious messages to  
stderr.  

Comment 6 Steven Shiau 2005-08-03 03:54:07 UTC
The problem is not only with mc, it will happen in dialog. When I use dialog, I
see the same error messages:
*** info [lib/liblow.c(329)]:
/dev/gpmctl: No such file or directory
*** err [lib/liblow.c(336)]:
/dev/gpmctl: No such file or directory
It should allow us to use dialog WITHOUT gpm running. gpm is not a necessary to
dialog.

Comment 7 Petr Rockai 2006-01-19 10:03:22 UTC
Fixed in FC devel. If GPM_VERBOSE envvar is set, libgpm will print output as  
before, otherwise it is silent. Do we want an update for FC4 for this? I am 
not sure if it's worth it, but if the problem is widespread enough, it may as 
well be. 


Note You need to log in before you can comment on or make changes to this bug.