Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1586161 - Kdump status is not detected
Summary: Kdump status is not detected
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra
Version: 4.2.4.1
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ---
: ---
Assignee: Eli Mesika
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-05 15:35 UTC by Petr Matyáš
Modified: 2018-06-07 10:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-07 10:02:34 UTC
oVirt Team: Infra
ykaul: exception?


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1517818 None None None Never

Internal Links: 1517818

Description Petr Matyáš 2018-06-05 15:35:41 UTC
Description of problem:
When I execute crash of a host which should initiate a kdump engine doesn't show that the host is in kdumping state and fences the host. This aborts the hosts attempt to dump the necessary information.

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.4.1-0.1.el7.noarch
vdsm-4.20.29-1.el7ev.x86_64

How reproducible:
always

Steps to Reproduce:
1. add power management agent to a host
2. execute kdump on that host (echo c > /proc/sysrq-trigger)
3.

Actual results:
host is fenced as usual with no regard to kdump

Expected results:
engine should detect that host is in kdumping state and should wait with fence action

Additional info:

Comment 3 Petr Matyáš 2018-06-06 15:58:11 UTC
Since I didn't change anything since the last time you made this working I don't understand what could I influence that the host would or would not be reachable.
In other words, I didn't change anything in the testing process since bug #1517818 even the host is the same.

Comment 4 Martin Perina 2018-06-07 06:57:55 UTC
It really depends on exception, NoRouteToHost means that there is no way how to reach the host itself using TCP/IP, which I think is the root cause why kdumping kernel cannot send packets to fence-kdump-listener running on engine.

So could you please turn on debuggin for fence-kdump listener by creating file /etc/sysconfig/ovirt-fence-kdump-listener with content:

OVIRT_SERVICE_DEBUG=1

And then please retry the test, capture stdout of kdumping kernel (to see IP/FQDN where kdumping kernel is sending packets) and attach relevant parts of fence-kdump-listener debug logs from journalctl. Thanks

Comment 6 Petr Matyáš 2018-06-07 10:02:34 UTC
Most likely a kernel (or something) issue, after update and reboot the issue is gone.


Note You need to log in before you can comment on or make changes to this bug.