Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158611 - Inconsistant clustat on two node cluster
Summary: Inconsistant clustat on two node cluster
Keywords:
Status: CLOSED DUPLICATE of bug 150346
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: rgmanager
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-23 22:52 UTC by Henry Harris
Modified: 2009-04-16 20:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-23 23:18:30 UTC


Attachments (Terms of Use)
cluster.conf (deleted)
2005-05-23 22:52 UTC, Henry Harris
no flags Details

Description Henry Harris 2005-05-23 22:52:53 UTC
Description of problem: With a two node cluster, running clustat on one node 
shows 2 active nodes.  Running clustat on the second node show only 1 active 
node.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results: Results from betamd02:

	[root@betamd02 ~]# clustat
	Member Status: Quorate, Group Member

	  Member Name                              State      ID
	  ------ ----                              -----      --
	  betamd02                                 Online     
0x0000000000000002

	  Service Name         Owner (Last)                   State
	  ------- ----         ----- ------                   -----
	  10.250.0.240         betamd02                       started
	[root@betamd02 ~]# clustat -x
	<?xml version="1.0"?>
	<clustat version="4.0">
	  <quorum quorate="1" groupmember="1"/>
	  <nodes>
	    <node name="betamd02" state="1" nodeid="0x0000000000000002"/>
	  </nodes>
	  <groups>
	    <group name="10.250.0.240" state="112" state_str="started"  
owner="betamd02" last_owner="none" restarts="0"/>
	  </groups>
	</clustat>
	[root@betamd02 ~]#


Results from betamd03:

	[root@betamd03 ~]# clustat
	Member Status: Quorate

	Not a member of the Resource Manager service group.
	Resource Group information unavailable; showing all cluster members.

	  Member Name                              State      ID
	  ------ ----                              -----      --
	  betamd02                                 Online     
0x0000000000000002
	  betamd03                                 Online     
0x0000000000000001

	[root@betamd03 ~]# clustat -x
	<?xml version="1.0"?>
	<clustat version="4.0">
	  <quorum quorate="1"/>
	</clustat>
	[root@betamd03 ~]#




Expected results:


Additional info:

Comment 1 Henry Harris 2005-05-23 22:52:53 UTC
Created attachment 114756 [details]
cluster.conf

Comment 2 Lon Hohberger 2005-05-23 23:18:30 UTC
rgmanager isn't running on the node reporting 2 nodes.



*** This bug has been marked as a duplicate of 150346 ***


Note You need to log in before you can comment on or make changes to this bug.