Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158609 - kernel hangs while "initializing hardware"
Summary: kernel hangs while "initializing hardware"
Keywords:
Status: CLOSED DUPLICATE of bug 154650
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-23 22:29 UTC by Don Buchholz
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-23 23:02:13 UTC


Attachments (Terms of Use)

Description Don Buchholz 2005-05-23 22:29:12 UTC
Description of problem:  System hangs on boot at "Initializing hardware ..."

Version-Release number of selected component (if applicable):  2.6.11-1.27_FC3 i686

How reproducible:  always

Steps to Reproduce: 
1.  boot with grub stanza containing "kernel /vmlinuz-2.6.11-1.27_FC3 ro
root=LABEL=/ vga=ext"
2.
3.
  
Actual results:  System prints out --
   Starting udev:
   Initializing hardware ... Disabling IRQ #10 


Expected results:  I expected system to boot and run, just like it did with the
2.6.9 kernels.


Additional info: 
Had no problem with earlier FC3 kernels (notably the 2.6.9-xxx series).
Not sure if my problems started w/ 2.6.10 or 2.6.11.

I can run if I specify "noapic apm=off acpi=off usb=off" in the boot options. 
(Found references to these options in other Bugzilla listings -- #138916 and
#151319.)  Fairly certain 'usb=off' doesn't affect the results.  Haven't had
time to play with the others to see which one really fixes the problem.


System is IBM Netfinity 4500R:
  * single 733MHz P-III processor
  * 512MB of memory
  * ServeRAID-3L card
  * 2nd ethernet card (LNE100TX -- uses 'tulip' driver)

# cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 3
cpu MHz         : 731.418
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
pse36 mmx fxsr sse
bogomips        : 1441.79


# lspci
00:00.0 Host bridge: ServerWorks CNB20LE Host Bridge (rev 05)
00:00.1 Host bridge: ServerWorks CNB20LE Host Bridge (rev 05)
00:01.0 VGA compatible controller: S3 Inc. Savage 4 (rev 04)
00:02.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE]
(rev 44)
00:09.0 SCSI storage controller: IBM SCSI RAID Adapter [ServeRAID] (rev 0d)
00:0f.0 ISA bridge: ServerWorks OSB4 South Bridge (rev 4f)
00:0f.1 IDE interface: ServerWorks OSB4 IDE Controller
00:0f.2 USB Controller: ServerWorks OSB4/CSB5 OHCI USB Controller (rev 04)
01:03.0 SCSI storage controller: Adaptec AIC-7899P U160/m (rev 01)
01:03.1 SCSI storage controller: Adaptec AIC-7899P U160/m (rev 01)
01:05.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 20)

Comment 1 Dave Jones 2005-05-23 23:02:13 UTC

*** This bug has been marked as a duplicate of 154650 ***


Note You need to log in before you can comment on or make changes to this bug.