Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158608 - rpmbuild incorrectly claims a symlink is unpackaged
Summary: rpmbuild incorrectly claims a symlink is unpackaged
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-05-23 21:52 UTC by Robin Green
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-23 23:01:20 UTC


Attachments (Terms of Use)
reduced test case (deleted)
2005-05-23 21:52 UTC, Robin Green
no flags Details

Description Robin Green 2005-05-23 21:52:54 UTC
Description of problem:
I was trying to build a package from jpackage, and rpmbuild bailed out with
"error: Installed (but unpackaged) file(s) found:" and gave the path of a
symlink. However, the symlink should have been matched by a wildcard in the
%files section. I manually expanded the wildcard, built again, and got the same
error. I have attached a reduced test case.

Version-Release number of selected component (if applicable):
rpm-build-4.4.1-20

How reproducible:
Always

Steps to Reproduce:
1. Download attached file testcase.spec
2. rpmbuild -bb testcase.spec
  
Actual results:
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.82777
+ umask 022
+ cd /usr/src/redhat/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.82777
+ umask 022
+ cd /usr/src/redhat/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.82777
+ umask 022
+ cd /usr/src/redhat/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ rm -rf /var/tmp/testcase-1.0-buildroot
+ mkdir -p /var/tmp/testcase-1.0-buildroot/usr/share
+ cd /var/tmp/testcase-1.0-buildroot/usr/share
+ touch dest
+ ln -s dest link
+ /usr/lib/rpm/redhat/brp-compress
+ /usr/lib/rpm/redhat/brp-strip /usr/bin/strip
+ /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/redhat/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
Processing files: testcase-1.0-1
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/testcase-1.0-buildroot
error: Installed (but unpackaged) file(s) found:
   /usr/share/link


RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/share/link


Expected results:
Should build successfully

Comment 1 Robin Green 2005-05-23 21:52:55 UTC
Created attachment 114750 [details]
reduced test case

Comment 2 Robin Green 2005-05-23 23:01:20 UTC
Upgraded rpm-libs to 4.4.1-20 and now I can't reproduce this bug. Marking as
RAWHIDE.


Note You need to log in before you can comment on or make changes to this bug.