Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158583 - dovecot can't authenticate yp users
Summary: dovecot can't authenticate yp users
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-23 19:28 UTC by Thomas J. Baker
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-29 15:27:43 UTC


Attachments (Terms of Use)
dovecot audit log (deleted)
2005-05-23 19:30 UTC, Thomas J. Baker
no flags Details

Description Thomas J. Baker 2005-05-23 19:28:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050512 Fedora/1.0.4-2 Firefox/1.0.4

Description of problem:
5/22/05 rawhide system. dovecot can't authenticate yp users.



Version-Release number of selected component (if applicable):
dovecot-0.99.14-4.fc4, selinux-policy-targeted-1.23.16-6

How reproducible:
Always

Steps to Reproduce:
1.start dovecot with the init script
2.try to connect and login using a yp account
3.
  

Actual Results:  authentication fails

Expected Results:  i can check my email

Additional info:

I'm having a similar problem with saslauthd.

Comment 1 Thomas J. Baker 2005-05-23 19:30:38 UTC
Created attachment 114735 [details]
dovecot audit log

audit log

Comment 2 Daniel Walsh 2005-05-23 20:54:38 UTC
Fixed in selinux-policy-targeted-1.23.16-7

Comment 3 Thomas J. Baker 2005-05-26 18:01:46 UTC
Any idea when this is going to get pushed?

Comment 4 Thomas J. Baker 2005-06-14 15:06:42 UTC
I just installed FC4 and it's still got selinux-policy-targeted-1.23.16-6.

Comment 5 Daniel Walsh 2005-06-15 18:53:10 UTC
Could you check selinux-policy-targeted-1.23.18-7 on
ftp://people.redhat.com/dwalsh/SELinux/FC4



Comment 6 Bojan Smojver 2005-06-18 04:01:13 UTC
selinux-policy-targeted-1.23.18-12 in testing updates still has the same
problem. I'm seeing this when authentication to an LDAP server is attempted via
PAM. Details from the log:

-----------------------------
Jun 18 13:56:00 beauty dovecot(pam_unix)[2705]: check pass; user unknown
Jun 18 13:56:00 beauty dovecot(pam_unix)[2705]: authentication failure; logname=
uid=0 euid=0 tty= ruser= rhost= 
Jun 18 13:56:00 beauty dovecot-auth[2705]: pam_ldap: ldap_starttls_s: Can't
contact LDAP server
Jun 18 13:56:00 beauty kernel: audit(1119066960.656:47): avc:  denied  { create
} for  pid=2705 comm="dovecot-auth" scontext=system_u:system_r:dovecot_auth_t
tcontext=system_u:system_r:dovecot_auth_t tclass=tcp_socket
Jun 18 13:56:00 beauty kernel: audit(1119066960.656:48): avc:  denied  { create
} for  pid=2705 comm="dovecot-auth" scontext=system_u:system_r:dovecot_auth_t
tcontext=system_u:system_r:dovecot_auth_t tclass=tcp_socket
Jun 18 13:56:00 beauty kernel: audit(1119066960.657:49): avc:  denied  { create
} for  pid=2705 comm="dovecot-auth" scontext=system_u:system_r:dovecot_auth_t
tcontext=system_u:system_r:dovecot_auth_t tclass=tcp_socket
-----------------------------

Comment 7 Caolan McNamara 2005-06-27 08:25:19 UTC
*** Bug 161604 has been marked as a duplicate of this bug. ***

Comment 8 Bojan Smojver 2005-06-28 23:21:58 UTC
This appears to be fixed in selinux-policy-targeted-1.23.18-17. However, I
cannot close this bug.


Note You need to log in before you can comment on or make changes to this bug.