Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158574 - adduser rewrites existing dot-files with /etc/skel files
Summary: adduser rewrites existing dot-files with /etc/skel files
Keywords:
Status: CLOSED DUPLICATE of bug 89591
Alias: None
Product: Fedora
Classification: Fedora
Component: shadow-utils
Version: 3
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-23 18:13 UTC by Aldy Hernandez
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-01 12:54:33 UTC


Attachments (Terms of Use)

Description Aldy Hernandez 2005-05-23 18:13:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
Adduser will rewrite *existing* files in /home/USER from the skeletons in /etc/skel.  This is especially dangerous if /home directories are NFS mounted (home is already populated).

For example, imagine I am adding user "foo" on a new machine that needs /etc/passwd populated.  If this machine has foo's home directory NFS mounted (or already present), it will overwrite any files there with the versions in /etc/skel.

Version-Release number of selected component (if applicable):
shadow-utils-4.0.3-57

How reproducible:
Always

Steps to Reproduce:
1. Create /home/foo with .bashrc.
2. adduser foo ...
3. See how /home/foo/.bashrc was rewritten.
  

Expected Results:  adduser should not overwrite existing files

Additional info:

Comment 1 Peter Vrabec 2005-08-01 12:54:33 UTC

*** This bug has been marked as a duplicate of 89591 ***


Note You need to log in before you can comment on or make changes to this bug.