Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158570 - udev not creating symlinks with kernel > 2.6.12-rc4
Summary: udev not creating symlinks with kernel > 2.6.12-rc4
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: udev
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 163438
TreeView+ depends on / blocked
 
Reported: 2005-05-23 17:30 UTC by Andrew Clayton
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-15 11:21:20 UTC


Attachments (Terms of Use)

Description Andrew Clayton 2005-05-23 17:30:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
When I plug in my external USB hard drive, I usually get a symlink, /dev/sd?1 pointing to /dev/usbhdd using this udev rule

BUS="usb", SYSFS{serial}="10000E00091DBEC1", KERNEL="sd?1", NAME="%k", SYMLINK="usbhdd"

This is in a file called 10-local.rules in /etc/udev/rules.d

I am currently seeing this problem with linux 2.6.12-rc4-git6

I think perhaps udev needs an update to work with kernels > 2.6.12-rc4 as noted from this post to lkml by Greg KH

http://www.ussg.iu.edu/hypermail/linux/kernel/0505.2/1368.html


Version-Release number of selected component (if applicable):
udev-039-10.FC3.7

How reproducible:
Always

Steps to Reproduce:
1. Create a custom udev rule in /etc/udev/rules.d/10-local.rules
2. Plug your device in
3.
  

Actual Results:  No symlinks were created.

Expected Results:  A symlink in /dev should have been created.

Additional info:

Comment 1 Martin Ebourne 2005-07-19 18:05:09 UTC
Now that a 2.6.12 kernel update has been put out as an update for FC3 this is
somewhat more of an issue. As per the comments above, udev needs to be updated
to version 058 to work with this updated kernel.

Quote from the link above:
  "Note, if you are running a kernel newer than 2.6.12-rc4 (including the
-mm releases) and you have any custom udev rules, you MUST upgrade to
the latest version to allow udev to work properly."

I've no choice but to downgrade the kernel again for now.

Note that this is not i386 specific (I'm on x86_64) but I can't change that.

Comment 2 Martin Ebourne 2005-09-12 19:41:18 UTC
FC4 has been on 058 for ages. Is there any reason that can't be recompiled for
FC3 and pushed out as an update to close this issue?

Comment 3 Harald Hoyer 2005-09-13 11:09:18 UTC
well, it would need other packages it depends on... like initscripts, hotplug,
mkinitrd, etc... which would require additional packages also... try it

Comment 4 Martin Ebourne 2005-09-18 12:01:21 UTC
I installed the FC4 udev package onto a fully updated FC3 box (x86_64).
Installed fine with no extra requirements. Seems ok. Wasn't able to check the
symlink functionality because that machine is already FC4.

I guess one reason for not releasing it as an update to FC3 is that it'll break
everyone's permissions.d rules, which isn't a good idea for a stable distro update.

The functionality all works fine on FC4, so this bug is FC3 only. Maybe a good
idea to WONTFIX this one.


Note You need to log in before you can comment on or make changes to this bug.