Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158567 - firstboot fails in boot module, self.myVbox not set
Summary: firstboot fails in boot module, self.myVbox not set
Keywords:
Status: CLOSED DUPLICATE of bug 178920
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhpl
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-23 16:53 UTC by Alexander Boström
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-27 20:29:57 UTC


Attachments (Terms of Use)
Stratus kickstart file (for customers) (deleted)
2005-10-26 19:17 UTC, Kimball Murray
no flags Details

Description Alexander Boström 2005-05-23 16:53:01 UTC
Description of problem:

Firstboot, when run automatically after kickstart, fails as soon as it's
started, with the following message:

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 502, in loadModules
    vbox, pix, title = module.launch()
  File
"/usr/src/build/430919-i386/install/usr/share/firstboot/modules/boot_gui.py",
line 177, in launch
    return FirstbootGuiWindow.launch(self)
  File "/usr/lib/python2.3/site-packages/rhpl/firstboot_gui_window.py", line
106, in launch
    internalVBox.pack_start(self.myVbox, gtk.TRUE)
AttributeError: BootWindow instance has no attribute 'myVbox'

After clicking OK, firstboot continues.

How reproducible:
If firstboot is killed and restarted, then the error is repeated, but I'm not
sure it happens on every install.

Steps to Reproduce:
1. boot from boot.iso, start kickstart
2. run install, reboot, wait for firstboot

Additional info:

Adding --debug to firstboot works around it. (Of course, then firstboot doesn't
do much). (See boot_gui.py:176)

I suppose the kickstart options are relevant. The ks.cfg is available if required.

Comment 1 Harald Hoyer 2005-07-07 11:27:24 UTC
# rpm -qf /usr/lib/python2.3/site-packages/rhpl/firstboot_gui_window.py
rhpl-???

please report the rhpl version number

Comment 2 Kimball Murray 2005-10-26 19:17:13 UTC
Created attachment 120426 [details]
Stratus kickstart file (for customers)

test case

Comment 3 Kimball Murray 2005-10-26 19:19:38 UTC
output from rpm version command on Stratus system running RHEL4-U2-GA is the
following:

rhpl-0.148.3-1

Comment 4 Chris Lumens 2006-02-27 20:29:57 UTC
Marking as a duplicate of a later bug because that one's already been added to
the proposed list.

*** This bug has been marked as a duplicate of 178920 ***

Comment 5 Kimball Murray 2006-08-28 16:46:30 UTC
A Stratus customer is hitting this bug at install time.  From Charlotte
Richardson (Stratus):

The symptom is that the RedHat firstboot window boot_gui.py
blows up (and doesn't configure the grub.conf file as a result) because
self.myVbox does not exist when the launch function in the python script
calls FirstbootGuiWindow unless doDebug is set. This seems to occur
because self.setupScreen, which creates the myVbox attribute along with many
others, only runs in the launch function if doDebug is set. You can see in the
stand_alone function it runs in either case before FirstbootGuiWindow
runs.

It appears that this is the problem: the launch function should run
setupScreen whether or not doDebug is set.



Note You need to log in before you can comment on or make changes to this bug.