Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158548 - cannot eject IDE-floppy disc
Summary: cannot eject IDE-floppy disc
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-23 14:36 UTC by David Balažic
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-14 15:14:43 UTC


Attachments (Terms of Use)

Description David Balažic 2005-05-23 14:36:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
in Fedora Core 4 test2 :

hdd is LS-120 CSMO 05 UHD Floppy, ATAPI FLOPPY drive

root# eject /dev/hdd
ide-floppy: hdd: I/O error, pc = 1b, key =  5, asc = 24, ascq =  0
eject: unable to eject, last error: Invalid argument


Version-Release number of selected component (if applicable):
eject-2.0.13-14

How reproducible:
Always

Steps to Reproduce:
1. try to eject the floppy with the above command

Actual Results:  error, see above

Expected Results:  floppy is ejected without error

Additional info:

Comment 1 Ngo Than 2005-06-15 15:23:38 UTC
if you press the eject-button on your floppy drive, does it work?

Could you please try eject-2.0.13-15.1. It's available on
ftp://people.redhat.com/than/fc4

Thanks

Comment 2 David Balažic 2005-06-16 07:37:41 UTC
Yes, unless the drive is locked by OS (when it is mounted).

Comment 3 Pete Zaitcev 2005-08-23 14:07:12 UTC
Surely this is incorrect:

+	if ((ioctl(fd, SG_GET_VERSION_NUM, &k) < 0) || (k < 30000)) {
+	  printf("not an sg device, or old sg driver\n");
+	  return 0;
+	}

Either it has to be an fprintf(stderr, foo), or if(v_option) printf().
I suggest the second form, because this is how the user would get
the actual device name, and the diagnostic has no meaning without
knowing that, due to the complicated discovery eject performs.

See also bug 154955.


Comment 4 Ngo Than 2005-08-23 17:29:26 UTC
David, i suppose the eject-2.0.13-15.1 has already fixed the problem.

if it's the case, i will do FC4 update for this.

Comment 5 Ngo Than 2005-09-14 15:14:43 UTC
ok, it seems a bug in ide-floppy driver, please take a look at  
http://www.gossamer-threads.com/lists/linux/kernel/568526  


Note You need to log in before you can comment on or make changes to this bug.