Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1585380 - [abrt] solaar: update(): window.py:775:update:AssertionError
Summary: [abrt] solaar: update(): window.py:775:update:AssertionError
Keywords:
Status: CLOSED DUPLICATE of bug 1487640
Alias: None
Product: Fedora
Classification: Fedora
Component: solaar
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eric Smith
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0b4f091cd18ed4ef28f440d046f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-02 08:42 UTC by Sylvain Réault
Modified: 2018-07-27 21:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-27 21:18:23 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2018-06-02 08:42 UTC, Sylvain Réault
no flags Details
File: cgroup (deleted)
2018-06-02 08:42 UTC, Sylvain Réault
no flags Details
File: cpuinfo (deleted)
2018-06-02 08:42 UTC, Sylvain Réault
no flags Details
File: environ (deleted)
2018-06-02 08:42 UTC, Sylvain Réault
no flags Details
File: mountinfo (deleted)
2018-06-02 08:42 UTC, Sylvain Réault
no flags Details
File: namespaces (deleted)
2018-06-02 08:42 UTC, Sylvain Réault
no flags Details
File: open_fds (deleted)
2018-06-02 08:42 UTC, Sylvain Réault
no flags Details

Description Sylvain Réault 2018-06-02 08:42:06 UTC
Version-Release number of selected component:
solaar-0.9.2-4.20150528gitcf27328.fc28.8

Additional info:
reporter:       libreport-2.9.5
cmdline:        /usr/bin/python2 /usr/bin/solaar
crash_function: update
exception_type: AssertionError
executable:     /usr/bin/solaar
interpreter:    python2-2.7.15-2.fc28.x86_64
kernel:         4.16.12-300.fc28.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
window.py:775:update:AssertionError

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/solaar/ui/__init__.py", line 165, in _status_changed
    window.update(device, need_popup)
  File "/usr/lib/python2.7/site-packages/solaar/ui/window.py", line 775, in update
    assert item
AssertionError

Local variables in innermost frame:
device: <UnifyingReceiver(/dev/hidraw2,16)>
item: None
is_alive: False
selected_device_id: None
need_popup: 0

Potential duplicate: bug 1506862

Comment 1 Sylvain Réault 2018-06-02 08:42:10 UTC
Created attachment 1446982 [details]
File: backtrace

Comment 2 Sylvain Réault 2018-06-02 08:42:11 UTC
Created attachment 1446983 [details]
File: cgroup

Comment 3 Sylvain Réault 2018-06-02 08:42:13 UTC
Created attachment 1446984 [details]
File: cpuinfo

Comment 4 Sylvain Réault 2018-06-02 08:42:14 UTC
Created attachment 1446985 [details]
File: environ

Comment 5 Sylvain Réault 2018-06-02 08:42:15 UTC
Created attachment 1446986 [details]
File: mountinfo

Comment 6 Sylvain Réault 2018-06-02 08:42:16 UTC
Created attachment 1446987 [details]
File: namespaces

Comment 7 Sylvain Réault 2018-06-02 08:42:17 UTC
Created attachment 1446988 [details]
File: open_fds

Comment 8 Jason Tibbitts 2018-07-27 21:18:23 UTC

*** This bug has been marked as a duplicate of bug 1487640 ***


Note You need to log in before you can comment on or make changes to this bug.