Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158538 - Cannot change print range/breaks using mouse
Summary: Cannot change print range/breaks using mouse
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
: 161604 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-23 13:37 UTC by Maxim Britov
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 2.0.4-5.5.17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-28 07:55:45 UTC


Attachments (Terms of Use)

Description Maxim Britov 2005-05-23 13:37:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Fedora/1.0.4-2 Firefox/1.0.4

Description of problem:
I can't change print range/breaks using mouse.
I only see sign like '+' and mouse select cells instead move print breaks :(

Version-Release number of selected component (if applicable):
openoffice.org-calc-1.9.104-1

How reproducible:
Always

Steps to Reproduce:
1. Create/open spreadsheet
2. Define print range
3. Try to change print range by mouse.
  

Actual Results:  Mouse select calls.

Expected Results:  Change print range or move page break (horizontal/vertical).

Additional info:

Thins is not new bug. I meet one about 2-3 mothes ago. afair
And please excuse my English :)

Comment 3 Maxim Britov 2005-06-14 08:36:48 UTC
$ rpm -q openoffice.org-calc
openoffice.org-calc-1.9.109-1.2.0.fc5

Still reproducible for me. Can't change print range. :(

Comment 4 poligraph 2005-06-14 09:13:55 UTC
(In reply to comment #3)
> $ rpm -q openoffice.org-calc
> openoffice.org-calc-1.9.109-1.2.0.fc5
> 
> Still reproducible for me. Can't change print range. :(

In Fedora Core 4 this problem still available...

Comment 5 Dan Williams 2005-06-14 11:50:39 UTC
Have you tried right-clicking on the page break, selecting "Delete", then adding
a break in the correct location by right-clicking and selecting "Insert column
break" or "Insert row break"?

Comment 6 Maxim Britov 2005-06-14 12:35:12 UTC
You cannot "Delete" automatically generated page breaks.
You may insert break after "autobreak". Can you remove "autobreak" now? I think no.

I asked man who using OOo 1.9.104 on Win32 (works fine).
Original builds worked fine for me untill I switched to Fedora builds :(
And I think this bug was introduced somewhere in Fedora builds.

Comment 7 Dan Williams 2005-06-14 13:03:11 UTC
No, you cannot remove an automatic page break.  But if you insert a manual page
break with the right-click menu, the automatic page break will go away.  You can
achieve the exact same effect with manual page breaks as you would like, since
in Office, moving a page break with your mouse converts it to a manual page
break anyway.  Moving it is no different than inserting a new manual break and
deleting the old one.

Comment 8 Maxim Britov 2005-06-14 13:33:32 UTC
Ok. I having 3 pages with 2 "autobreaks" and I wants to move secont page break
down. How I can do it?
After inserting page breaks after 2nd "autobreak" I get 3rd break and I cannot
remove 2nd break, because it still be automatical break. In resault I will have
4 pages instead 3 with rescaled 2nd page.

Comment 9 Maxim Britov 2005-06-20 10:00:48 UTC
I just test openoffice.org-calc 1.9.109 from OOo - works fine. I see arrows and
I can change print ranges. Current OOo from Fedora doesn't it :(
Still waiting :)


Comment 10 Caolan McNamara 2005-06-27 13:58:23 UTC
*** Bug 161604 has been marked as a duplicate of this bug. ***

Comment 11 Maxim Britov 2005-07-11 08:58:54 UTC
Still reproducible in openoffice.org-calc-1.9.116-1.2.0.fc5 :(

Comment 12 Chris Shaffer 2005-08-12 16:25:00 UTC
Also reproducible in openoffice.org-calc-1.9.117-3.1.0.fc4.  To accomplish page
breaks as desired, I have to reboot to Windows :(

Comment 13 Dan Williams 2005-08-12 16:51:18 UTC
yeah, its a bug and needs to get fixed.

Comment 14 Maxim Britov 2005-10-05 15:05:43 UTC
openoffice.org-calc-2.0.0-1.2.2
still reproducible

Comment 15 Maxim Britov 2006-02-21 16:08:08 UTC
Great! Waiting FC5 with this bug! Still reproducible in rawhide

Comment 18 Maxim Britov 2006-07-20 06:38:37 UTC
This regression still present in Fedora Core 4, Fedora Core 5 and in Fedora 6
rawhide.

Comment 19 Caolan McNamara 2007-03-28 07:55:45 UTC
I've made some improvements in the latest FC-6 update 2.0.4-5.5.17. This is as
good as it gets given the constraints I'm under here.


Note You need to log in before you can comment on or make changes to this bug.