Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158531 - i18ntable tags
Summary: i18ntable tags
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-23 12:13 UTC by Jeff Johnson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-27 07:50:24 UTC


Attachments (Terms of Use)

Description Jeff Johnson 2005-05-23 12:13:43 UTC
Description of problem:

rpm is generating again i18ntable tags (100). These tags seem to be
empty strings right now (due to i18n not being included in packages since RHL 6.2).

Since these tags are not used, I think they should be removed again.

Also default rpm should not add such tags to make the default rpm more
usable for ISV vendors to use it.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Paul Nasrat 2005-05-23 13:53:39 UTC
Other distributions such as PLD, Connectiva (and thus I assume Mandriva) use
i18n tags, packages in Fedora Extras use i18n tags.

>>> import os, rpm
>>> ts=rpm.ts()
>>> f = open("allegro-4.0.3-7.i386.rpm")
>>> h = ts.hdrFromFdno(f.fileno())
>>> h[100]
['C', 'es', 'fr', 'it']




Note You need to log in before you can comment on or make changes to this bug.