Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158530 - filecontext tags
Summary: filecontext tags
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-23 11:44 UTC by Florian La Roche
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-27 07:47:51 UTC


Attachments (Terms of Use)

Description Florian La Roche 2005-05-23 11:44:19 UTC
Description of problem:

rpm is generating again filecontext tags (1147). These tags seem to be
empty strings right now (due to build hosts not having selinux enabled).

Since these tags are not used, I think they should be removed again.

Also default rpm should not add such tags to make the default rpm more
usable for ISV vendors to use it.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeff Johnson 2005-05-23 14:13:36 UTC
Other distributions such as PLD, Connectiva (and thus I assume Mandriva) can use
filecontext tags. Packages in Fedora Extras might use filecontext tags as a more
reliable (because static content) delivery mechanism than current *.te/*.fc with
dynamic (and hence stateful) application.


Note You need to log in before you can comment on or make changes to this bug.