Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158528 - xterm resource "eightBitInput" should be false
Summary: xterm resource "eightBitInput" should be false
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xterm
Version: 4.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard: RHEL4U3NAK
: 158524 158525 158526 158527 (view as bug list)
Depends On:
Blocks: 187538
TreeView+ depends on / blocked
 
Reported: 2005-05-23 10:24 UTC by Kjetil T. Homme
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: RHBA-2006-0350
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-10 22:12:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0350 normal SHIPPED_LIVE xterm bug fix update 2006-05-10 04:00:00 UTC

Description Kjetil T. Homme 2005-05-23 10:24:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-1.3.1

Description of problem:
this is a regression.  in RHEL 3, /usr/X11R6/lib/X11/app-defaults/XTerm contains this comment:

! Bug fix for bugzilla bug #49315
*VT100*eightBitInput: false

this has been removed in RHEL 4.  unfortunately, the named bug is inaccessible to non-employees.  anyway, without this fix, meta keys (M-b and M-f to move a word backward and forward, for instance) doesn't work in Bash or other readline enhanced applications, which obviously is quite irritating.

Version-Release number of selected component (if applicable):
xterm-192-1

How reproducible:
Always

Steps to Reproduce:
1. start XTerm with bash
2. type "foo"
3. type Meta-b
  

Actual Results:  I get the character LATIN CAPITAL LETTER A WITH CIRCUMFLEX (bugzilla couldn't handle the raw character :-)

Expected Results:  the cursor should move to the beginning of the word "foo"

Additional info:

Comment 1 Miloslav Trmač 2005-05-23 15:12:08 UTC
*** Bug 158524 has been marked as a duplicate of this bug. ***

Comment 2 Miloslav Trmač 2005-05-23 15:12:16 UTC
*** Bug 158525 has been marked as a duplicate of this bug. ***

Comment 3 Miloslav Trmač 2005-05-23 15:12:18 UTC
*** Bug 158526 has been marked as a duplicate of this bug. ***

Comment 4 Miloslav Trmač 2005-05-23 15:12:23 UTC
*** Bug 158527 has been marked as a duplicate of this bug. ***

Comment 9 Mike A. Harris 2005-06-30 17:30:17 UTC
Committed fix to xterm-192-1.EL4.1, now on list of potential candidates
to include in RHEL4U2 or later.

xterm-192-1.EL4.1 is now available for download via ftp at the following URL: 
ftp://people.redhat.com/mharris/testing/4E

Setting status to "MODIFIED" pending testing.

Comment 21 Red Hat Bugzilla 2006-05-10 22:12:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0350.html



Note You need to log in before you can comment on or make changes to this bug.