Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158519 - Vino keyboard handling issues
Summary: Vino keyboard handling issues
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: vino
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Søren Sandmann Pedersen
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-23 08:42 UTC by Mark McLoughlin
Modified: 2014-06-18 09:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2008-0727
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-24 19:57:57 UTC


Attachments (Terms of Use)
vino-2.10.0-fix-over-eager-key-repeat.patch (deleted)
2005-05-23 08:44 UTC, Mark McLoughlin
no flags Details | Diff
vino-2.10.0-fix-broken-shift-with-some-keys.patch (deleted)
2005-05-23 08:45 UTC, Mark McLoughlin
no flags Details | Diff
vino-2.10.0-fix-caps-lock.patch (deleted)
2005-05-23 08:46 UTC, Mark McLoughlin
no flags Details | Diff
vino-2.10.0-fix-over-eager-key-repeat.patch (deleted)
2005-09-30 10:14 UTC, Mark McLoughlin
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0727 normal SHIPPED_LIVE vino bug fix and enhancement update 2008-07-23 16:09:28 UTC

Description Mark McLoughlin 2005-05-23 08:42:48 UTC
Several bugs with Vino's keyboard handling code:

bug #134451:

  Over-eager repeat rate. Whenever you type something which causes a large
  part of the screen to change (e.g. adding a newline in the middle of a 
  screenfull of text), you'd often either get a lot of extra newlines or
  Vino would go into an infinite loop adding newlines.

bug #140515:

  Shift key not working with some keys. Made it impossible to enter '|' or
  "£" with some very common keyboard layouts.

bug #142974

   Caps Lock wouldn't work at all.

Attaching the fixes.

Comment 1 Mark McLoughlin 2005-05-23 08:44:52 UTC
Created attachment 114705 [details]
vino-2.10.0-fix-over-eager-key-repeat.patch

Comment 2 Mark McLoughlin 2005-05-23 08:45:24 UTC
Created attachment 114706 [details]
vino-2.10.0-fix-broken-shift-with-some-keys.patch

Comment 3 Mark McLoughlin 2005-05-23 08:46:39 UTC
Created attachment 114707 [details]
vino-2.10.0-fix-caps-lock.patch

Comment 5 Mark McLoughlin 2005-05-23 10:09:01 UTC
Pending fix in vino-2.8.1-1.1; errata is RHBA-2005:477

Comment 9 Mark McLoughlin 2005-09-30 10:12:38 UTC
Relatively minor issue with the over-eager-key-repeat patch reported in Fedora -
bug #158713, attaching updated patch

Comment 10 Mark McLoughlin 2005-09-30 10:14:00 UTC
Created attachment 119456 [details]
vino-2.10.0-fix-over-eager-key-repeat.patch

Comment 17 RHEL Product and Program Management 2006-09-05 19:52:43 UTC
The component this request has been filed against is not planned for inclusion
in the next update. The decision is based on weighting the priority and number
of requests for a component as well as the impact on the Red Hat Enterprise
Linux user-base: other components are considered having higher priority and the
number of changes we intend to include in update cycles is limited.

Comment 18 RHEL Product and Program Management 2006-09-05 20:04:30 UTC
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Comment 19 Ludek Smid 2008-04-02 13:45:00 UTC
Since this component got included in the next update, reopening this bug.

Comment 20 RHEL Product and Program Management 2008-04-02 13:58:51 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 22 Cameron Meadors 2008-06-13 15:02:59 UTC
I cannot reproduce 134451 and 140515 with the old packages, but I could
reproduce 142974.

I would like to note that this will make it impossible to put this bug into
VERIFIED since that requires reproduction on old packages and verifying that the
bug is fixed on the new packages.  Please stick to one issue per bug.

Comment 23 Cameron Meadors 2008-06-13 15:23:15 UTC
No change in new packages.  142974 is still broken.

Comment 25 Søren Sandmann Pedersen 2008-06-18 21:20:02 UTC
I cannot reproduce these bugs either:

   bug #134451
   bug #140515

For 140515, note that it says with "some" keys, so it's possible some unusual
keyboard layout would be required. We'd have to ask Mark about that.



Comment 26 Cameron Meadors 2008-06-23 20:39:33 UTC
142974 was reproduced and verified as fixed.  I am leaving this in ON_QA because
I can not reproduce the other two bugs.

Comment 28 errata-xmlrpc 2008-07-24 19:57:57 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0727.html


Note You need to log in before you can comment on or make changes to this bug.