Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158516 - Key RWIN is mapped to button4 in X-Server
Summary: Key RWIN is mapped to button4 in X-Server
Keywords:
Status: CLOSED DUPLICATE of bug 154448
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-23 08:08 UTC by Dov Grobgeld
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-23 08:13:16 UTC


Attachments (Terms of Use)

Description Dov Grobgeld 2005-05-23 08:08:04 UTC
Description of problem:

The key <RWIN> on the keyboard (the second key to the right of the space bar) is
mapped by the x-server to button4. This makes it impossible to assign a mapping
to this key. In my particular case, it makes the following line in my .xkbmap
not to work:
   
    key <RWIN>  {       [  Multi_key], [Multi_key] };

Version-Release number of selected component (if applicable):

fonts-xorg-100dpi-6.8.2-1
xorg-x11-font-utils-6.8.2-31
xorg-x11-xfs-6.8.2-31
xorg-x11-devel-6.8.2-31
xorg-x11-deprecated-libs-6.8.2-31
fonts-xorg-base-6.8.2-1
xorg-x11-xauth-6.8.2-31
xorg-x11-deprecated-libs-devel-6.8.2-31
xorg-x11-twm-6.8.2-31
xorg-x11-6.8.2-31
xorg-x11-xdm-6.8.2-31
xorg-x11-libs-6.8.2-31
xorg-x11-Mesa-libGL-6.8.2-31
xorg-x11-tools-6.8.2-31
xorg-x11-Mesa-libGLU-6.8.2-31
fonts-xorg-75dpi-6.8.2-1

How reproducible:

Everytime

Steps to Reproduce:
1. Run 'xev'
2. Move mouse to xev window
3. Press RWIN key
  
Actual results:

Terminal prints:

ButtonPress event, serial 25, synthetic NO, window 0x1800001,
    root 0x58, subw 0x0, time 1055989, (91,151), root:(160,236),
    state 0x0, button 4, same_screen YES

ButtonRelease event, serial 25, synthetic NO, window 0x1800001,
    root 0x58, subw 0x0, time 1055989, (91,151), root:(160,236),
    state 0x800, button 4, same_screen YES


Expected results:

I would expect to get a keypress event, and thus get something like this.

KeyPress event, serial 25, synthetic NO, window 0x1800001,
    root 0x58, subw 0x0, time 1088976, (146,90), root:(215,175),
    state 0x0, keycode 114 (keysym ????, Multi_Key), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 28, synthetic NO, window 0x1800001,
    root 0x58, subw 0x0, time 1089030, (146,90), root:(215,175),
    state 0x2000, keycode 114 (keysym ???, Multi_Key), same_screen YES,
    XLookupString gives 0 bytes: 



Additional info:

Comment 1 Dov Grobgeld 2005-05-23 08:13:16 UTC

*** This bug has been marked as a duplicate of 154448 ***


Note You need to log in before you can comment on or make changes to this bug.