Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158511 - layout issue in some web pages with pango enabled
Summary: layout issue in some web pages with pango enabled
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On: 140902
Blocks: FIREFOX_PANGO
TreeView+ depends on / blocked
 
Reported: 2005-05-23 06:09 UTC by Lawrence Lim
Modified: 2014-03-26 00:52 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-13 02:13:24 UTC


Attachments (Terms of Use)
firefox with pango enables in zh_TW locale (deleted)
2005-05-23 06:09 UTC, Lawrence Lim
no flags Details
screenshot on yahoo KR rendering (deleted)
2006-01-17 01:20 UTC, Leon Ho
no flags Details
screesshot ontained from <http://image.yahoo.com.cn/> (deleted)
2006-02-02 04:53 UTC, Lawrence Lim
no flags Details
screenshot got from yahoo hk website (deleted)
2006-09-11 03:29 UTC, Nicole Dai
no flags Details
screenshot got from yahoo kr website (deleted)
2006-09-11 03:34 UTC, Nicole Dai
no flags Details
screenshot got from yahoo hk website opened by IE (deleted)
2006-09-11 06:55 UTC, Nicole Dai
no flags Details
screenshot got from yahoo kr website opened by IE (deleted)
2006-09-11 06:57 UTC, Nicole Dai
no flags Details

Description Lawrence Lim 2005-05-23 06:09:17 UTC
+++ This bug was initially created as a clone of Bug #140902 +++

Description of problem:
With pango enabled, firefox is unable to display the layout properly
in some web pages.

Version-Release number of selected component (if applicable):
firefox-1.0-4.EL4

How reproducible:
Always

Steps to Reproduce:
1.LANG=zh_TW.UTF-8 firefox
2.go to the following URL, http://hk.yahoo.com/
3.
  
Actual results:
layout is not displayed properly. please refer to screenshot

Expected results:
should be display properly, similar to pango disabled

Additional info:

Comment 1 Lawrence Lim 2005-05-23 06:09:18 UTC
Created attachment 114698 [details]
firefox with pango enables in zh_TW locale

Comment 2 Akira TAGOH 2005-12-07 09:58:36 UTC
Well, "properly" sounds like vague and it may be hard to understand for non-CJK
people what's wrong. that screenshot shows some characters though, it looks like
the baseline of glyphs are lower than what we expected. so the bottom of glyphs
are rendered to out of rectangle.

Comment 3 Leon Ho 2006-01-17 01:20:51 UTC
Created attachment 123276 [details]
screenshot on yahoo KR rendering

firefox 1.5 is getting better in rawhide, however there are still some serious
layout problems in some languages.

Comment 4 Lawrence Lim 2006-02-02 04:53:56 UTC
Created attachment 124028 [details]
screesshot ontained from <http://image.yahoo.com.cn/>

Tested with firefox-1.5-5, there is still some layout issues. As tagoh-san
mentioned in Comment #2, one of the issue indeed could be due the baseline of
glyhs setting lower than expected.

Comment 5 Akira TAGOH 2006-09-06 13:46:05 UTC
firefox-1.5.0.6 looks much better than the previous versions. need to confirm if
there are still any pages having this issue.

Comment 6 Nicole Dai 2006-09-11 03:29:58 UTC
Created attachment 135957 [details]
screenshot got from yahoo hk website

The layout issues were still found in firefox-1.5.0.6-11.

Comment 7 Nicole Dai 2006-09-11 03:34:41 UTC
Created attachment 135958 [details]
screenshot got from yahoo kr website

Comment 8 Nicole Dai 2006-09-11 06:55:39 UTC
Created attachment 135968 [details]
screenshot got from yahoo hk website opened by IE

The layout issues were found in firefox regardless of MOZ_DISABLE_PANGO
setting.
But it is no problem when open the web pages by IE. Please refer to the
attached screenshot. Thanks.

Comment 9 Nicole Dai 2006-09-11 06:57:35 UTC
Created attachment 135969 [details]
screenshot got from yahoo kr website opened by IE

Comment 10 Christopher Aillon 2006-09-11 17:29:59 UTC
So, this is not specific to pango then?

Comment 11 Lawrence Lim 2006-09-13 02:13:24 UTC
Agreed. Resolving and opening a new bug 206227 for the layout issue. Thanks for
the investigation Nicole.


Note You need to log in before you can comment on or make changes to this bug.