Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158509 - Texts in non-embedded cjk font disappear
Summary: Texts in non-embedded cjk font disappear
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xpdf
Version: 4
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Mike McLean
URL: http://www2.novac.co.jp/support/remix...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-23 05:54 UTC by Yoshihiro Kosakai
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-23 09:50:13 UTC


Attachments (Terms of Use)

Description Yoshihiro Kosakai 2005-05-23 05:54:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7.8) Gecko/20050512 Fedora/1.0.4-2 Firefox/1.0.4

Description of problem:
Xpdf of FC4 sometimes refuses to display japanese texts.
Especially, as to /usr/bin/pdffonts, embedded fonts are displayed correctly while non-embedded ones go wrong.

Since FC4 Test, it seems to have changed the directory names in /usr/share/fonts.
For example /usr/share/fonts/ja to /usr/share/fonts/japanese,
.../zh_CN to .../chinese, and so on.
Actually the files included from /etc/xpdfrc are to be updated.

Now I'm taking a workaround making my own $HOME/.xpdfrc with correct paths, but everyone should be happy if this is default.


Version-Release number of selected component (if applicable):
xpdf-3.00-18

How reproducible:
Always

Steps to Reproduce:
1. install fonts-japanese package
2. make a PDF including some non-embedded cjk fonts or download a URL above
3. open it
  

Actual Results:  Non-embedded fonts aren't displayed.
(There must be japananese words between ``Sound MX'' and the horizontal line in the title page of the downloaded file.)

Expected Results:  Displayed using a system's default font.


Additional info:

Evince viewer cannot, too.

Comment 1 Ngo Than 2005-05-23 09:50:13 UTC
it's now fixed in xpdf-3.00-19. Many thanks for your reports.


Note You need to log in before you can comment on or make changes to this bug.