Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158499 - findfs fails to find label after install
Summary: findfs fails to find label after install
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Mike McLean
URL:
Whiteboard:
: 158500 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-23 02:30 UTC by Adam Hitchcock
Modified: 2008-02-16 15:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-16 15:47:15 UTC


Attachments (Terms of Use)
Strace of findfs (deleted)
2005-05-27 14:55 UTC, Paul Nasrat
no flags Details

Description Adam Hitchcock 2005-05-23 02:30:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412 (KHTML, like Gecko) Safari/412

Description of problem:
Installation completes correctly, however, upon attempting to mount the / partition it gives the error

>Checking filesystems  [ FAIL ]
>fsck.ext3: Unable to resolve 'LABEL=/'

in /etc/fstab line 1
LABEL=/   /   ext3 defaults 1 1
should be:
/dev/hdaX   /   ext3 defaults 1 1
(where X is where / is located)

to fix from the recovery prompt you must remount the / partition in read/write mode, edit /etc/fstab, 
remount / in read only, reboot.
to do this do thus:
1. enter password
2. $> mount -o remount,rw /
3. $> vi /etc/fstab
4. change LABEL=/ to just have it pointing to /dev/hdaX 
5. $> mount -o remount,ro /
6. $> Ctrl-D

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install fedora core 4 test 3
2. let machine reboot
3. see error
  

Actual Results:  Checking filesystems  [ FAIL ]
>fsck.ext3: Unable to resolve 'LABEL=/'

in /etc/fstab line 1
LABEL=/   /   ext3 defaults 1 1

Expected Results:  The machine should finish the booting normally.

in /etc/fstab line 1
/dev/hdaX   /   ext3 defaults 1 1
(where X is where / is located)

Additional info:

I have only tried this on my iBook 500 dual usb thus far, I will attempt to reproduce it on on other PPC 
machines.

Comment 1 Paul Nasrat 2005-05-23 13:57:06 UTC
*** Bug 158500 has been marked as a duplicate of this bug. ***

Comment 2 Jeremy Katz 2005-05-23 15:36:12 UTC
What does e2label /dev/hdaX show?

Comment 3 Jeremy Katz 2005-05-23 17:51:24 UTC
Note:  I just tried this on my 400 mhz imac and it works fine.  Used partitions
instead of LVM and thus LABEL=/ is being mounted as / and fsck was fine.

Comment 5 Paul Nasrat 2005-05-27 14:55:43 UTC
Created attachment 114913 [details]
Strace of findfs

I've just hit this here:

e2label /dev/hda3 
/boot

findfs LABEL=/boot fails
Unable to resolve 'LABEL=/boot'

Comment 6 Paul Nasrat 2005-05-27 15:17:49 UTC
/etc/blkid.tab is empty.

Comment 7 Paul Nasrat 2005-05-27 15:29:35 UTC
In addition blkid -c /tmp/foo generates an empty cache file



Comment 8 Thomas Woerner 2005-05-27 16:37:40 UTC
Found the problem: It was a strange date:
# date
Sat Jan  9 01:34:48 EST 1904


Comment 9 Richard Hughes 2006-01-25 22:10:34 UTC
"unable to resolve LABEL=/boot"

My date of /etc/blkid.tab is 01/01/1904.

I edited /etc/fstab by hand to use /dev/hda3 so I could get fc5t2 to finish
installing (and rawhide has the same issue btw) but this is obviously a bug for FC5.

Powerbook has no cmos battery anymore, and relies on ntp for the time and date,
which probably explains the dodgey date.

Comment 10 Christian Iseli 2007-01-22 11:41:39 UTC
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.

Comment 11 Matthew Miller 2007-04-06 15:06:56 UTC
Fedora Core 3 and Fedora Core 4 are no longer supported. If you could retest
this issue on a current release or on the latest development / test version, we
would appreciate that. Otherwise, this bug will be marked as CANTFIX one month
from now. Thanks for your help and for your patience.


Comment 12 Red Hat Bugzilla 2007-08-21 05:20:17 UTC
User pnasrat@redhat.com's account has been closed

Comment 13 petrosyan 2008-02-16 15:47:15 UTC
Fedora Core 4 is no longer maintained.

Setting status to "INSUFFICIENT_DATA". If you can reproduce this bug in the
current Fedora release, please reopen this bug and assign it to the
corresponding Fedora version.


Note You need to log in before you can comment on or make changes to this bug.