Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158489 - weird pause before actions occur in OOo.
Summary: weird pause before actions occur in OOo.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-22 23:33 UTC by Rodd Clarkson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.9.108-4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-10 15:12:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 44627 None None None Never

Description Rodd Clarkson 2005-05-22 23:33:35 UTC
Description of problem:

There's this weird pause I'm getting between doing some actions and the action
looking like it's happened.

I've seen this before, but I can actually pin down how to reproduce some examples.


Version-Release number of selected component (if applicable):

openoffice.org-core-1.9.104-1

How reproducible:

Very

Steps to Reproduce:
1. Open a OOo Writer.
2. Click File > Save As and then type in a name to save the file as.
3. Now, very carefully (I'm on a laptop so this is easy) place the mouse pointer
over the Save button and click it without moving the mouse.
4. Wait a bit.  Now look at the top of the OOo window and note that the file
name isn't there yet.  Move the mouse around and the window flashes and the file
name appears.

5. Now, click File > Save As
6. Click Save, doing the same thing we did last time (so as not to disturb the
mouse pointer after the click.
7. Give it a moment (long enough to realize that "The file already exists. 
Overwrite?" dialog should have well and truly appeared but hasn't).
8. Move that mouse pointer and the dialog appears.

9. Now, try this. Click File > Save As again.
10. Move the dialog away from the OOo Writer window (or other OOo windows). 
Essentially, you wont to be sure that when you click Save, you're mouse won't be
over any OOo window.
11. Click Save and then move your mouse around staying clear of OOo windows. 
Note that you haven't seen that "Overwrite file?" dialog.
12. Move the mouse pointer into the OO window and the dialog appears.

Additional info:

For some reason, OOo seams to be delaying some actions until the mouse (or
possibly some other use driven event) triggers the action to occur, but when no
trigger should be needed.  For example, clicking Save should be enough of a
trigger (don't you think ;-]) without having to move the mouse inside a OOo
window for the save event to occur.

Comment 1 Caolan McNamara 2005-06-02 09:53:14 UTC
Yeah, there's a nasty interaction there due to
http://qa.openoffice.org/issues/show_bug.cgi?id=44627.

You're correct, OOo waits for the dialog to be finished. The dialog says it's
finished, but OOo isn't detecting this until someother event comes along, i.e.
wiggle the mouse a bit.

Will patch for 1.9.106-1

Comment 2 Caolan McNamara 2005-06-09 12:16:09 UTC
*** Bug 157158 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.