Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158487 - Eth i/f shutdown order cause unclean PPPoE termination
Summary: Eth i/f shutdown order cause unclean PPPoE termination
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora Legacy
Classification: Retired
Component: initscripts
Version: rhl9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Fedora Legacy Bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-22 22:45 UTC by Francois-Xavier 'FiX' KOWALSKI
Modified: 2007-04-18 17:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-25 05:15:35 UTC


Attachments (Terms of Use)

Description Francois-Xavier 'FiX' KOWALSKI 2005-05-22 22:45:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
When stopping the network (e.g. at shutdown time), ppp interfaces are shut-down after ethernet interfaces:


This causes the PPP link to be abruptly brought down -- without a termination handshake with the peer -- & hance may delay the required reconnection time when the peer xDSL router is facing high load.

In the case of PPPoE (my case), PPP interfaces should be brought down *before* Ethernet interfaces.  I do not know the sensible order for usual PPP interfcaes (e.g. over dialup).

Version-Release number of selected component (if applicable):
initscripts-7.14-1

How reproducible:
Always

Steps to Reproduce:
One of the below

1. service netzork stop
2. shutdown
3. reboot
  

Actual Results:  Shutdown sequence:

Shutting down interface eth0:  [  OK  ]
Shutting down interface eth1:  [  OK  ]
Shutting down interface ppp0:  [  OK  ]


Expected Results:  Shutdown sequence:

Shutting down interface ppp0:  [  OK  ]
Shutting down interface eth0:  [  OK  ]
Shutting down interface eth1:  [  OK  ]


Additional info:

2 ethernet i/f:

- eth0 serving my LAN (10 MBytes/sec switch)
- eth1 connected (x-cable) to my xDSL modem

2 PPP i/f:

- ppp0 on-demand dialup
- ppp1 PPPoE

Comment 1 Pekka Savola 2005-05-25 05:15:35 UTC
Fedora Legacy is only doing security backports, and this doesn't seem to be one
of such.   So the issue is unsupported.

Quickly looking at more recent init.d/network, there you have:

        for i in $cipeinterfaces $xdslinterfaces $bridgeinterfaces
$vlaninterfaces; do
                eval $(fgrep "DEVICE=" ifcfg-$i)
                if [ -z "$DEVICE" ] ; then DEVICE="$i"; fi
                                                                               
          
                if ! check_device_down $DEVICE; then
                   action $"Shutting down interface $i: " ./ifdown $i boot
                fi
        done
                                                                               
          
        # shut down all interfaces (other than loopback)
        for i in $remaining ; do
[...]

so, there's currently some provision for shutting down xDSL interfaces first,
just as long as the interface definition includes:

TYPE=xDSL


Note You need to log in before you can comment on or make changes to this bug.