Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158485 - openoffice.org clashes with missing libjawt.so.6
Summary: openoffice.org clashes with missing libjawt.so.6
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
: 158411 158613 (view as bug list)
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-05-22 21:35 UTC by Warren Togami
Modified: 2007-11-30 22:11 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-29 06:11:39 UTC


Attachments (Terms of Use)

Description Warren Togami 2005-05-22 21:35:21 UTC
Description of problem:
openoffice.org-core-1.9.104-1 is incompatible with the latest gcc-4.0.0-8 stack
in dist-fc4, causing a dependency clash and upgrade failure.  This is a FC4Blocker.

What changed and why?

Comment 1 Dan Williams 2005-05-22 23:33:49 UTC
Umm, gcc-4.0.0-8 changed the AWT library from libjawt.so -> libgcjawt.so because
proprietary VMs use libjawt and gcj shouldn't clash with them.  While
libgcjawt.so supposedly gets symlinked to libjawt.so, OOo currently relies upon
"-ljawt".

So, OOo uses a JAVA_HOME variable to point to the base of the JDK.  Well, for
GCJ that's "/usr" because that's where bin/java and bin/javac are rooted from. 
However, that's _not_ where the rest of the java libraries are...  We should
probably be pointing at "/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0" now, but that may
clash with assumptions scattered around the code that were made before the
java-gcj-compat packages were developed.

I'm trying a build pointed to the new location, we'll see how it goes.


Comment 2 Bojan Smojver 2005-05-23 01:55:04 UTC
This should be marked as duplicate of bug #158411.

And yes, I'm seeing it too :-(

Comment 3 Warren Togami 2005-05-23 02:02:39 UTC
*** Bug 158411 has been marked as a duplicate of this bug. ***

Comment 4 Dan Williams 2005-05-23 20:46:39 UTC
A fix for the gcjawt library is in CVS, and a new copy of OOo is building now to
fix some utter berkeleydb stupidity (which was blocking the rebuild this weekend).

Comment 5 Jeremy Katz 2005-05-23 23:22:56 UTC
Package is building now.

Comment 6 Dan Williams 2005-05-24 13:40:21 UTC
*** Bug 158613 has been marked as a duplicate of this bug. ***

Comment 7 Thomas Fitzsimmons 2005-05-24 14:34:37 UTC
In response to Comment #1:

On the compile line that specifies -ljawt, add (or modify the existing -L to be):

-L%{_jvmdir}/java/jre/lib/%{_arch}


Comment 8 Thomas Fitzsimmons 2005-05-24 20:02:31 UTC
Actually, this should be: -L%{_jvmdir}/jre/lib/%{_arch}, since only
java-1.4.2-gcj-compat may be installed (and not java-1.4.2-gcj-compat-devel).

But looking at the spec file, you've linked directly to libgcjawt.so, which is
fine too.


Comment 9 Warren Togami 2005-05-24 20:40:46 UTC
http://people.redhat.com/wtogami/temp/openoffice/
I copied binaries here for i386 for testing.


Note You need to log in before you can comment on or make changes to this bug.