Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158482 - hal actions unreliable
Summary: hal actions unreliable
Keywords:
Status: CLOSED DUPLICATE of bug 156167
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-22 20:40 UTC by Michal Jaegermann
Modified: 2013-03-06 03:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-22 21:39:43 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2005-05-22 20:40:48 UTC
Description of problem:

In https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id= #c12
there is a claim that "latest builds should have this fixed".
That is correct only in a small extent.  Namely when I am pluging in
a USB floppy the first time after a reboot with 2.6.11-1.1329_FC4 kernel
then it is correctly recognized and, if media are present, mounted.

Unmounting, unplugging and plugging it back results in the following
in dmesg:

usb 5-1: new full speed USB device using uhci_hcd and address 5
scsi6 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 5
usb-storage: waiting for device to settle before scanning
  Vendor: SONY      Model: USB-FDU           Rev: 5.01
  Type:   Direct-Access                      ANSI SCSI revision: 00
SCSI device sdb: 1440 512-byte hdwr sectors (1 MB)
sdb: Write Protect is on
sdb: Mode Sense: 00 46 1e 80
sdb: assuming drive cache: write through
SCSI device sdb: 1440 512-byte hdwr sectors (1 MB)
sdb: Write Protect is on
sdb: Mode Sense: 00 46 1e 80
sdb: assuming drive cache: write through
 sdb: unknown partition table
Attached scsi removable disk sdb at scsi6, channel 0, id 0, lun 0
usb-storage: device scan complete

but 'lshal' this time for the same device says, among other things:

storage.hotpluggable = false  (bool)
storage.drive_type = 'disk'  (string)

(this was true and 'floppy' on the previous attempt) and I can only
mount "manually" /dev/sdb - which works fine.

To make things more interesting once hal suddenly recognized
storage.drive_type = 'floppy' on the fourth or fifth attempt but I was
unable to repeat that feat.  OTOH the first time after a reboot,
repeated with a few reboots, consistently works.

No idea if this is another demonstration of bug #156167 or another problem.

Version-Release number of selected component (if applicable):
hal-0.5.2-1

Comment 1 David Zeuthen 2005-05-22 21:11:05 UTC
Thanks for the traces. When you see

 storage.hotpluggable = false  (bool)
 storage.drive_type = 'disk'  (string)

do you also see 

 storage.bus = 'scsi'

If you do, this is a probably a duplicate of bug 156167.

Comment 2 Michal Jaegermann 2005-05-22 21:36:07 UTC
> do you also see storage.bus = 'scsi'

The first time this is storage.bus = 'usb' and the second time
storage.bus = 'scsi'.

> If you do, this is a probably a duplicate of bug 156167

Well, with bug 156167 this was wrong bus all the time.  Sigh, I copied
not that URL in the original report
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=156167#c12
suggests that this was fixed.  So either this fix was incomplete
or this is something new.  Yes, I left a note in bug 156167 too.

Comment 3 David Zeuthen 2005-05-22 21:39:43 UTC
So, this bug report suggests that the fix in bug 156167 is not good. I'll close
this is a duplicate (as it surely is one) and change the state of bug 156167.
Thanks for the testing.

*** This bug has been marked as a duplicate of 156167 ***


Note You need to log in before you can comment on or make changes to this bug.