Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158474 - hald services quits, audit msgs in log
Summary: hald services quits, audit msgs in log
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: 4
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2005-05-22 17:49 UTC by Doug Henderson
Modified: 2013-03-06 03:43 UTC (History)
1 user (show)

Fixed In Version: 0.5.2-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-05-23 15:54:23 UTC

Attachments (Terms of Use)
output from hald, and gdb of core file (deleted)
2005-05-22 20:56 UTC, Doug Henderson
no flags Details
execution log and gdb output (deleted)
2005-05-22 21:29 UTC, Doug Henderson
no flags Details

Description Doug Henderson 2005-05-22 17:49:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
When I ran up2date to add new packages, it failed to see the just inserted CD.
I checked services and found that haldaemon was stopped. Started it and inserted
disk. Icon popped up on Gnome desktop. I ejected the disk and started up2date
again. Again, it failed to see the just inserted disk. Again observed that
haldaemon was stopped.

I observed the following messages in /var/log/messages:
May 22 10:28:43 lambda kernel: agpgart: Putting AGP V2 device at 0000:02:00.0 into 1x mode
May 22 11:01:02 lambda crond(pam_unix)[21054]: session opened for user root by (uid=0)
May 22 11:01:02 lambda crond(pam_unix)[21054]: session closed for user root
May 22 11:03:36 lambda kernel: audit(1116781416.708:0): avc:  denied  { write } for  path="pipe:[365856]" dev=pipefs ino=365856 scontext=root:system_r:hald_t tcontext=root:system_r:unconfined_t tclass=fifo_file
May 22 11:03:37 lambda fstab-sync[21196]: removed all generated mount points
May 22 11:03:37 lambda fstab-sync[21205]: added mount point /media/floppy for /dev/fd0
May 22 11:03:38 lambda fstab-sync[21208]: added mount point /media/cdrecorder for /dev/hdc
May 22 11:04:58 lambda kernel: SELinux: initialized (dev hdc, type iso9660), uses genfs_contexts

I suspect a problem with selinux due to audit message.

System is up-to-date with 2005.05.21 rawhide, except for the gcc 4.0.0-8 group of packages.


[root@lambda ~]# cat /proc/ide/ide1/hdc/model 

My upgrade path is FC3 to FC4test2 to FC4test3 using CDROM (not DVD) media.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. start haldaemon (if necessary)
2. run up2date 
3. selecting packages which cause media request
4. insert media when requested

Actual Results:  When I hit OK on the media request dialog, an error box came up about no media.

Expected Results:  Package loads from media

Additional info:

This has worked before, since upgrade to FC4test3.

Comment 1 David Zeuthen 2005-05-22 18:37:09 UTC
Can you reproduce this with selinux disabled? (boot with selinux=0 on the kernel

Comment 2 Doug Henderson 2005-05-22 19:31:50 UTC
Booted with selinux=0
(BTW, how do you query the selinux status to confirm this?)

Did telinit 5 to start gnome desktop. Waited for desktop startup to finish.

Clicked on red Redhat network icon to check which packages need updating. The
list includes the gcc 4.0.0-8 group of packages only.

Started server configuration tool to check status of haldaemon. It was running.

Started add/remove applications tool and selected applications.

At insert disk 2 prompt, inserted disk 2, waited for cd light to go out, pressed
ok on that dialog.

Received "Unable to access disk" error dialog.

Checked haldaemon in server configuration tool. It was stopped.

Comment 3 David Zeuthen 2005-05-22 19:43:32 UTC
Use selinuxenabled to query wheter selinux is running (there's a man page as well). 

Ensure that haldaemon isn't running and then please attach the output of

 '/usr/sbin/hald --daemon=no --verbose=yes --retain-privileges'

to this bug. I think hald may be crashing or something. Also, if you can get a
stack trace (see ) if hald
crashes, that would be great.

Comment 4 Doug Henderson 2005-05-22 20:53:34 UTC
see attachment named bug-158474-c.txt

It took several tries to get this info. I decided that the first couple of tries
were not sufficiently reproducable due to previous failures. So I rebooted, but
with disk 2 still in the cd drive. I opened the tray, before I ran the
add/remove apps tool. When it asked for the disk, it sucked in the tray and
installed the packages. I tried again with other packages. Now it asked for disk
3, and loaded the packages.

So, I stopped and started hald with services tool. I opened tray and removed
disk (leaving tray open). Started add/remove tray tool, and pushed in empty
tray. At that point I observed that hald had failed.

Attached is the partial output (last 1200 or so lines) from hald execution, and
gdb session doing backtrace on core file.

I twice repeated with tray empty and closed. I made sure that all hald processes
were killed - manually killed the hald-addon-acpi and hald-addon-storage left
around when hald crashed.

I believe hald is crashing very soon after I start the add/remove tool, possibly
before it displays scanning system progress bar.

Comment 5 Doug Henderson 2005-05-22 20:56:16 UTC
Created attachment 114691 [details]
output from hald, and gdb of core file

partial output from executing hald with this command line:
/usr/sbin/hald --daemon=no --verbose=yes --retain-privileges

This is the last 1200 or so lines from the terminal window.

Output from gdb looks a bit sparse - no symbols?

Comment 6 David Zeuthen 2005-05-22 21:13:50 UTC
Have you installed the hal-debuginfo packages? This package contain the symbols.
It looks like there's a double-free somewhere, if I can get traces with symbols
it would probably be much easier to fix. Thanks.

Comment 7 Doug Henderson 2005-05-22 21:29:19 UTC
Created attachment 114692 [details]
execution log and gdb output

installed hal-debuginfo

repeated test.

Comment 8 David Zeuthen 2005-05-23 15:54:23 UTC
I was able to reproduce this and fix the bug. Should be fixed in tomorrows Rawhide.

Note You need to log in before you can comment on or make changes to this bug.