Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158451 - libsafe - FC4 x86_64 rebuild failed
Summary: libsafe - FC4 x86_64 rebuild failed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libsafe
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thorsten Leemhuis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE4Target-x86_64
TreeView+ depends on / blocked
 
Reported: 2005-05-22 12:43 UTC by Thorsten Leemhuis
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-24 06:59:26 UTC


Attachments (Terms of Use)

Description Thorsten Leemhuis 2005-05-22 12:43:08 UTC
This package failed to rebuild on x86_64 for FC4 Development around 2005-04-11
after an automated release bump. No build logs available afaics.

Please request a rebuild.

Comment 1 Warren Togami 2005-05-22 12:52:01 UTC
x86_64 is unsupported.  libsafe is i386 only.


*** This bug has been marked as a duplicate of 143327 ***

Comment 2 Thorsten Leemhuis 2005-05-22 15:45:54 UTC
(In reply to comment #1)
> x86_64 is unsupported.  libsafe is i386 only.
> 
> *** This bug has been marked as a duplicate of 143327 ***

Okay -- what's this then: 
http://download.fedora.redhat.com/pub/fedora/linux/extras/development/x86_64/libsafe-2.0-16.fdr.1.rh80.x86_64.rpm
Should it be removed?

And why can gentoo build for x86_64 when we can't:
http://mozilla.mirrors.tds.net/pub/gentoo-portage/sys-libs/libsafe/libsafe-2.0_p16-r1.ebuild

Comment 3 Warren Togami 2005-05-22 21:08:27 UTC
Does it actually work?  Until somebody proves that it works it should be
removed.  It can be dangerous otherwise.

Comment 4 Thorsten Leemhuis 2005-05-24 06:39:20 UTC
(In reply to comment #3)
> Does it actually work?  Until somebody proves that it works it should be
> removed.  It can be dangerous otherwise.

Reopening -- I'll look into that (meat: fix it or remove it from x86_64 before FC4)



Comment 5 Thorsten Leemhuis 2005-05-24 06:40:53 UTC
s/meat/means/

Comment 6 Warren Togami 2005-05-24 06:42:45 UTC
With FORTIFY_SOURCE libsafe is mostly redundant, and might actually be avoided
for most library calls since the built binaries call the *_chk equivalents. 
libsafe was useful before FORTIFY_SOURCE in cases where you were unable to use
the protection of exec-shield.

libsafe should theoretically not be dangerous on i386 though.  I don't think it
is worth the effort on x86_64.  There is plenty other higher priority stuff
needing fixing for FC4.

Comment 7 Thorsten Leemhuis 2005-05-24 06:59:26 UTC
(In reply to comment #6)
> I don't think it is worth the effort on x86_64. 

Okay, I filled a remove request for the x86_64-package on
http://www.fedoraproject.org/wiki/Extras_2fFC4Status

> There is plenty other higher priority stuff
> needing fixing for FC4.

;-)


Note You need to log in before you can comment on or make changes to this bug.