Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158437 - evince: corrupted double-linked list: 0x000000383d8326f8 ***
Summary: evince: corrupted double-linked list: 0x000000383d8326f8 ***
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evince
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marco Pesenti Gritti
QA Contact:
URL:
Whiteboard:
: 156805 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-22 11:25 UTC by Tim Waugh
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-06 09:59:46 UTC


Attachments (Terms of Use)
scorecard_final_01.pdf (deleted)
2005-05-22 11:25 UTC, Tim Waugh
no flags Details

Description Tim Waugh 2005-05-22 11:25:24 UTC
Description of problem:
When closing evince I get this error message.

Version-Release number of selected component (if applicable):
evince-0.2.1-1
poppler-0.3.0-2
glibc-2.3.5-6

How reproducible:
100%

Steps to Reproduce:
1. evince scorecard_final_01.pdf
2. Close the window
  
Actual results:
*** glibc detected *** evince: corrupted double-linked list: 0x000000383d8326f8 ***
======= Backtrace: =========
/lib64/libc.so.6[0x383d66a2a0]
/lib64/libc.so.6[0x383d66b2f6]
/lib64/libc.so.6(calloc+0x96)[0x383d66c906]
/usr/lib64/libglib-2.0.so.0(g_malloc0+0x28)[0x383e32ab96]
/usr/lib64/libglib-2.0.so.0[0x383e318b87]
/usr/lib64/libglib-2.0.so.0(g_hash_table_remove+0xab)[0x383e31977c]
/usr/lib64/libgobject-2.0.so.0(g_signal_handlers_destroy+0x5b)[0x383e51d832]
/usr/lib64/libgobject-2.0.so.0(g_closure_invoke+0xfb)[0x383e50a27d]
/usr/lib64/libgobject-2.0.so.0[0x383e517489]
/usr/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0x696)[0x383e51880c]
/usr/lib64/libgobject-2.0.so.0(g_signal_emit+0x83)[0x383e518bb7]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b3451c084]
/usr/lib64/libgobject-2.0.so.0(g_object_run_dispose+0x42)[0x383e50b913]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b34493e2d]
/usr/lib64/libgobject-2.0.so.0(g_closure_invoke+0xfb)[0x383e50a27d]
/usr/lib64/libgobject-2.0.so.0[0x383e517489]
/usr/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0x696)[0x383e51880c]
/usr/lib64/libgobject-2.0.so.0(g_signal_emit+0x83)[0x383e518bb7]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b3451c084]
/usr/lib64/libgobject-2.0.so.0(g_object_run_dispose+0x42)[0x383e50b913]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b34462563]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b34493e2d]
/usr/lib64/libgobject-2.0.so.0(g_closure_invoke+0xfb)[0x383e50a27d]
/usr/lib64/libgobject-2.0.so.0[0x383e517489]
/usr/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0x696)[0x383e51880c]
/usr/lib64/libgobject-2.0.so.0(g_signal_emit+0x83)[0x383e518bb7]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b3451c084]
/usr/lib64/libgobject-2.0.so.0(g_object_run_dispose+0x42)[0x383e50b913]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b34493e2d]
/usr/lib64/libgobject-2.0.so.0(g_closure_invoke+0xfb)[0x383e50a27d]
/usr/lib64/libgobject-2.0.so.0[0x383e517489]
/usr/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0x696)[0x383e51880c]
/usr/lib64/libgobject-2.0.so.0(g_signal_emit+0x83)[0x383e518bb7]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b3451c084]
/usr/lib64/libgobject-2.0.so.0(g_object_run_dispose+0x42)[0x383e50b913]
/usr/lib64/libgtk-x11-2.0.so.0(gtk_main_do_event+0x3f1)[0x3b345025d5]
/usr/lib64/libgdk-x11-2.0.so.0[0x3b34840051]
/usr/lib64/libglib-2.0.so.0(g_main_context_dispatch+0x1d5)[0x383e32499e]
/usr/lib64/libglib-2.0.so.0[0x383e327644]
/usr/lib64/libglib-2.0.so.0(g_main_loop_run+0x192)[0x383e327b30]
/usr/lib64/libgtk-x11-2.0.so.0(gtk_main+0xa1)[0x3b34501a75]
evince(main+0x1bc)[0x420370]
/lib64/libc.so.6(__libc_start_main+0xdc)[0x383d61c4cc]
evince(__gxx_personality_v0+0x201)[0x412589]
======= Memory map: ========
00400000-0043a000 r-xp 00000000 03:01 2270321                           
/usr/bin/evince
0053a000-00543000 rw-p 0003a000 03:01 2270321                           
/usr/bin/evince
00543000-00897000 rw-p 00543000 00:00 0
40000000-40001000 ---p 40000000 00:00 0
40001000-40a01000 rw-p 40001000 00:00 0
30ecb00000-30ecb14000 r-xp 00000000 03:01 2253209                       
/usr/lib64/libgdk_pixbuf-2.0.so.0.600.7
30ecb14000-30ecc14000 ---p 00014000 03:01 2253209                       
/usr/lib64/libgdk_pixbuf-2.0.so.0.600.7
30ecc14000-30ecc16000 rw-p 00014000 03:01 2253209                       
/usr/lib64/libgdk_pixbuf-2.0.so.0.600.7
30ecd00000-30ecd02000 r-xp 00000000 03:01 4695619                       
/lib64/libcom_err.so.2.1
30ecd02000-30ece01000 ---p 00002000 03:01 4695619                       
/lib64/libcom_err.so.2.1
30ece01000-30ece02000 rw-p 00001000 03:01 4695619                       
/lib64/libcom_err.so.2.1
30ed100000-30ed116000 r-xp 00000000 03:01 2262163                       
/usr/lib64/libgssapi_krb5.so.2.2
30ed116000-30ed215000 ---p 00016000 03:01 2262163                       
/usr/lib64/libgssapi_krb5.so.2.2
30ed215000-30ed217000 rw-p 00015000 03:01 2262163                       
/usr/lib64/libgssapi_krb5.so.2.2
30ed300000-30ed370000 r-xp 00000000 03:01 2262162                       
/usr/lib64/libkrb5.so.3.2
30ed370000-30ed46f000 ---p 00070000 03:01 2262162

Expected results:
No error message.

Additional info:
Doesn't seem to happen on i386.

Comment 1 Tim Waugh 2005-05-22 11:25:25 UTC
Created attachment 114687 [details]
scorecard_final_01.pdf

Comment 2 Marco Pesenti Gritti 2005-06-01 08:30:26 UTC
Is this still reproducable with evince 0.3.1?

Comment 3 Marco Pesenti Gritti 2005-06-01 08:54:29 UTC
*** Bug 156805 has been marked as a duplicate of this bug. ***

Comment 4 Tim Waugh 2005-06-01 09:00:23 UTC
No, I can't reproduce it with 0.3.1.

Comment 5 Dan Bolser 2005-08-22 09:31:23 UTC
When will this bug get fixed in the FC4 repos?

I have evince 0.3.1 (FC4), and the bug is very much alive.


Note You need to log in before you can comment on or make changes to this bug.