Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158436 - Syntax error before 'access_vector_t' at checkpolicy
Summary: Syntax error before 'access_vector_t' at checkpolicy
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: checkpolicy
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-05-22 11:01 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 1.23.4-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-09 08:38:13 UTC


Attachments (Terms of Use)
checkpolicy-1.23.4 (deleted)
2005-05-30 08:38 UTC, Tomo Vuckovic
no flags Details

Description Robert Scheck 2005-05-22 11:01:05 UTC
Description of problem:
Rebuilding of checkpolicy dies with these messages:

[...]
cc -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32 -march=i386 -mtune=pentium4 -fasynchronous-unwind-tables -I. -I/usr/include -o y.tab.o -c y.tab.c
In file included from policy_parse.y:38:
checkpolicy.h:11: error: syntax error before 'access_vector_t'
checkpolicy.h:11: warning: no semicolon at end of struct or union
checkpolicy.h:14: error: syntax error before '}' token
checkpolicy.h:14: warning: data definition has no type or storage class
checkpolicy.h:16: error: syntax error before '*' token
checkpolicy.h:16: warning: data definition has no type or storage class
policy_parse.y: In function 'define_common_perms':
policy_parse.y:973: error: 'access_vector_t' undeclared (first use in this function)
policy_parse.y:973: error: (Each undeclared identifier is reported only once
policy_parse.y:973: error: for each function it appears in.)
policy_parse.y: In function 'define_av_perms':
policy_parse.y:1080: error: 'access_vector_t' undeclared (first use in this function)
policy_parse.y: At top level:
policy_parse.y:2207: error: syntax error before 'access_vector_t'
policy_parse.y: In function 'av_to_string':
policy_parse.y:2216: error: 'tclass' undeclared (first use in this function)
policy_parse.y:2219: error: 'av' undeclared (first use in this function)
policy_parse.y: At top level:
policy_parse.y:2327: error: syntax error before 'access_vector_t'
policy_parse.y: In function 'te_avtab_helper':
policy_parse.y:2335: error: 'which' undeclared (first use in this function)
policy_parse.y:2340: error: 'tclasses' undeclared (first use in this function)
policy_parse.y:2343: error: 'stype' undeclared (first use in this function)
policy_parse.y:2344: error: 'ttype' undeclared (first use in this function)
policy_parse.y:2366: error: 'avp' undeclared (first use in this function)
policy_parse.y: At top level:
policy_parse.y:2387: error: syntax error before 'access_vector_t'
policy_parse.y: In function 'cond_te_avtab_helper':
policy_parse.y:2395: error: 'which' undeclared (first use in this function)
policy_parse.y:2403: error: 'tclasses' undeclared (first use in this function)
policy_parse.y:2407: error: 'stype' undeclared (first use in this function)
policy_parse.y:2408: error: 'ttype' undeclared (first use in this function)
policy_parse.y:2417: error: 'avp' undeclared (first use in this function)
policy_parse.y: In function 'define_cond_te_avtab':
policy_parse.y:2449: error: 'access_vector_t' undeclared (first use in this function)
policy_parse.y:2449: error: 'avp' undeclared (first use in this function)
policy_parse.y: In function 'define_te_avtab':
policy_parse.y:2625: error: 'access_vector_t' undeclared (first use in this function)
policy_parse.y:2625: error: 'avp' undeclared (first use in this function)
policy_parse.y:2628: error: 'newassert' undeclared (first use in this function)
make: *** [y.tab.o] Error 1
[...]

Version-Release number of selected component (if applicable):
checkpolicy-1.23.1-1

How reproducible:
Everytime, try to rebuild checkpolicy.

Actual results:
No rebuilding.

Expected results:
Rebuilding.

Additional info:
Maybe similar problem like at policycoreutils a few days ago, but 1.23.4-1
from CVS wasn't built in Rawhide, yet.

Comment 1 Tomo Vuckovic 2005-05-30 08:38:59 UTC
Created attachment 114964 [details]
checkpolicy-1.23.4

New version of checkpolicy :-)

Comment 2 Tomo Vuckovic 2005-05-30 08:40:24 UTC
View checkpolicy attachment.

Comment 3 Daniel Walsh 2005-05-30 09:43:04 UTC
Fixed in 1.23.4-1

Comment 4 Robert Scheck 2005-05-30 10:11:24 UTC
Tomo, rebuilding of your package ends with

[...]
cc -g -Wall -O2 -pipe -I. -I/var/tmp/checkpolicy-buildroot/usr/include -o queue.o -c queue.c
cc -o checkpolicy y.tab.o lex.yy.o queue.o checkpolicy.o -lfl /var/tmp/checkpolicy-buildroot/usr/lib/libsepol.a
cc: /var/tmp/checkpolicy-buildroot/usr/lib/libsepol.a: No such file or directory
make: *** [checkpolicy] Error 1

at my system, but the original error message seems to be gone. Can we also
get rid of this? ;-)

Comment 5 Daniel Walsh 2005-05-30 12:00:36 UTC
Do you have libsepol-devel installed?

Comment 6 Tomo Vuckovic 2005-05-30 12:12:54 UTC
working with : rpmbuild --rebuild checkpolicy-1.23.4-1.ato.src.rpm


Comment 7 Robert Scheck 2005-05-30 12:24:43 UTC
Oops...comment #4 was my mistake. So -4 works, waiting for rebuild in Rawhide.

Comment 8 Robert Scheck 2005-06-09 08:38:13 UTC
1.23.4-1 was built in Rawhide, closing now.


Note You need to log in before you can comment on or make changes to this bug.