Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158425 - selinux policy reload hangs the kernel
Summary: selinux policy reload hangs the kernel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-22 05:40 UTC by Alexandre Oliva
Modified: 2015-01-04 22:19 UTC (History)
2 users (show)

Fixed In Version: kernel-2.6.11-1.1337_FC4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-22 07:05:44 UTC


Attachments (Terms of Use)
oops from text-mode install, after installing selinux-policy-targeted (deleted)
2005-05-22 06:38 UTC, Alexandre Oliva
no flags Details
bottom of the oops at boot-up for relabel (deleted)
2005-05-22 06:41 UTC, Alexandre Oliva
no flags Details

Description Alexandre Oliva 2005-05-22 05:40:25 UTC
Description of problem:
When installing FC4-re0520.0 with selinux targeted policy enabled, when we
install selinux-policy-targeted, an oops makes it to the console.  Later on,
when we install selinux-policy-targeted-sources, the policy is reloaded and then
the system freezes hard.  If we choose not to install
selinux-policy-targeted-sources, the hard freeze happens during the installer's
final configuration stage.

Install succeeds booting the installer with selinux=0, but then, if you
re-enable selinux in /etc/sysconfig/selinux, touch /.autorelabel, and reboot,
the system will fail to boot with kernel oopses very early during the boot. 
I've taken some pictures of the oopses, which I'll attach upon request.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1329_FC4

How reproducible:
Always, both x86_64 and i686

Steps to Reproduce:
1.Boot kernel 2.6.11-1.1329_FC4 with selinux targeted policy in enforcing mode

Comment 1 Dave Jones 2005-05-22 05:47:05 UTC
sure, please attach the oopses.


Comment 2 Dave Jones 2005-05-22 05:47:40 UTC
also give the latest kernel a try (-1337 right now), and see if that fixes it


Comment 3 Alexandre Oliva 2005-05-22 06:38:30 UTC
Created attachment 114682 [details]
oops from text-mode install, after installing selinux-policy-targeted

On a text install, without selinux=0, an oops is displayed while running the
selinux-policy-targeted %post.	The install proceeds, so the screen gets
somewhat garbled, but I hope the critical info from the oops is still there.

Comment 4 Alexandre Oliva 2005-05-22 06:41:28 UTC
Created attachment 114683 [details]
bottom of the oops at boot-up for relabel

When booting up for relabel, I think a number of oopses is displayed, but they
roll off the screen too fast for me to even count them.  Sorry about the poor
picture quality, it was the best of 3 I took after it froze :-(

Comment 5 Alexandre Oliva 2005-05-22 07:05:44 UTC
Looks like 1337 is fixed.


Note You need to log in before you can comment on or make changes to this bug.