Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158409 - Hal doesn't detect USB key after reinserting.
Summary: Hal doesn't detect USB key after reinserting.
Keywords:
Status: CLOSED DUPLICATE of bug 156167
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-22 00:37 UTC by Rodd Clarkson
Modified: 2013-03-06 03:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-22 00:57:32 UTC


Attachments (Terms of Use)

Description Rodd Clarkson 2005-05-22 00:37:47 UTC
Description of problem:

Hal correctly detects my UCB key the first time I connect it after starting FC4,
and then mounts the filesystem, along with placing an item in Computer.

However, after ejecting the stick and removing it from the usb socket, hal
doesn't detect it on subsequent attempts to use.

This makes it quite painful to use to transfer files (you can't plu it in, then
eject it and unplug it and then replug it in).

Version-Release number of selected component (if applicable):

hal-0.5.2-1

How reproducible:

Everytime (every reboot)


Steps to Reproduce:
1. Insert USB key.
2. Eject USB key by right clicking icon on desktop and then selecting eject.
3. Remove UCB key.
4. Re-insert USB key
  
Actual results:

USB key isn't recognised by hal on subsequent insertions.


Expected results:

USB key should be recognised and then handled appropriately (in this case
mounted and an icon placed on the desktop and in computer)

Additional info:

I don't have problems with other dissimilar usb products like mice and keyboards.

I'll try to get outputs for lshal before inserting the usb key for the first
time, after the first insertion and then after a sebsequent insertion.  (I'll
need to reboot to do this)

Comment 1 David Zeuthen 2005-05-22 00:57:32 UTC

*** This bug has been marked as a duplicate of 156167 ***


Note You need to log in before you can comment on or make changes to this bug.