Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158396 - "Forward" button gets disabled
Summary: "Forward" button gets disabled
Keywords:
Status: CLOSED DUPLICATE of bug 166034
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-05-21 14:57 UTC by petrosyan
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-17 21:35:52 UTC


Attachments (Terms of Use)

Description petrosyan 2005-05-21 14:57:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Fedora/1.0.4-2 Firefox/1.0.4

Description of problem:
Try using up2date gui to upgrade lots of packages.
Now in the screen "Available Package Updates" click on "Select all packages" and then deselect at least 1 of them. The "Forward" button gets disabled.

The correct behavior is: "Forward" button should be disabled if _all_ packages get deselected.

Version-Release number of selected component (if applicable):
up2date-4.4.23-3

How reproducible:
Always

Steps to Reproduce:
1. start up2date
2. press next until reach "Available Package Updates"
3. check "Select all packages" checkbox
4. deselect at least one of the selected packages
  

Actual Results:  "Forward" button is disabled

Expected Results:  "Forward" button should get disabled only if all of the packages get deselected

Additional info:

Comment 1 Joachim Frieben 2005-07-14 11:52:35 UTC
I have observed the exactly identical behaviour for "up2date-4.4.23-4". The
trick to get around this problem is of course to unselect at least one package
more than you actually want to and to reselect it. In this case, the "forward"
button gets active again, and one can proceed to installing the remaining packages.

Comment 2 petrosyan 2005-09-17 21:35:52 UTC

*** This bug has been marked as a duplicate of 166034 ***


Note You need to log in before you can comment on or make changes to this bug.