Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158378 - Source fails to link against glut
Summary: Source fails to link against glut
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: freeglut
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-21 08:10 UTC by Paul F. Johnson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-25 06:46:51 UTC


Attachments (Terms of Use)
Source code used to generate the reported error (deleted)
2005-05-21 08:10 UTC, Paul F. Johnson
no flags Details

Description Paul F. Johnson 2005-05-21 08:10:27 UTC
Description of problem:
When linking against freeglut, glViewPort is not undefined. I have checked the
GL.so file and glViewPort does have a symbol.

Version-Release number of selected component (if applicable):
freeglut-2.2.0-16
freeglut-devel-2.2.0-16

How reproducible:
Always

Steps to Reproduce:
1. Compile the attachment using -lm -lGL -lGLU -lglut -lX11 -L/usr/X11R6/lib
2.
3.
  
Actual results:
/tmp/ccgoPbqG.o(.text+0x75): In function `reshape':
cube.c: undefined reference to `glViewPort'
collect2: ld returned 1 exit status

Expected results:
Source compiles

Additional info:

Comment 1 Paul F. Johnson 2005-05-21 08:10:27 UTC
Created attachment 114662 [details]
Source code used to generate the reported error

Comment 2 Mike A. Harris 2005-05-24 14:01:24 UTC
File a bug report in freeglut's bug tracker on sourceforge, and paste the
URL to the report here, and we'll track the issue.  If freeglut developers
determine it to be a freeglut bug and provide a patch to fix it, we'll
consider it for inclusion in a future update.

Thanks in advance.

Comment 3 Mike A. Harris 2005-05-24 14:02:51 UTC
Setting status to "NEEDINFO", awaiting upstream bug URL.

Comment 4 Mike A. Harris 2005-05-25 06:46:51 UTC
Actually after reviewing this again briefly, this is a bug in your code,
not a bug in freeglut.

You're misnaming function calls.  In the future, please use a public mailing
list for assistance prior to filing a bug report.

Setting status to "NOTABUG".


Note You need to log in before you can comment on or make changes to this bug.