Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 158356 - Can't fence nodes with WTI NPS-115 switch if on dual power supplies
Summary: Can't fence nodes with WTI NPS-115 switch if on dual power supplies
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: fence
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-20 20:31 UTC by Wendy Cheng
Modified: 2018-11-14 18:20 UTC (History)
4 users (show)

Fixed In Version: ??
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-30 19:52:45 UTC


Attachments (Terms of Use)
Backport from 6.1 (deleted)
2005-05-23 21:57 UTC, Lon Hohberger
no flags Details

Description Wendy Cheng 2005-05-20 20:31:20 UTC
Description of problem:

The current fence_wti.pl doesn't seem to be able to handle WTI NPS-115 with
*dual* power supplies. The customer has been unable to fence the nodes of their
cluster - look like only one of the power supplies is turned off. 

Is there any workaround available at this moment ? 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Lon Hohberger 2005-05-23 19:01:57 UTC
No workarounds at the moment, besides using a Y-adapter for power.

Comment 2 Lon Hohberger 2005-05-23 21:39:15 UTC
According to the other engineers, a backport from RHCS4 / RHGFS 6.1 to RHGFS 6.0
isn't a backport at all; it's as simple as replacing the outdated fencing agent
with the newer (correct) one from 6.1.

Comment 3 Adam "mantis" Manthei 2005-05-23 21:54:49 UTC
FYI:  according to the manual
(http://www.redhat.com/docs/manuals/csgfs/admin-guide/s1-sf-dualfence.html):

   "GFS supports dual power-supply fencing with the APC MasterSwitch only; 
    it supports multipath FC fencing with Brocade and Vixel switches."

Another workaround to thisfeature request is to plug in only a single power
supply at this time.

Comment 4 Lon Hohberger 2005-05-23 21:57:09 UTC
Created attachment 114752 [details]
Backport from 6.1

Comment 5 Wendy Cheng 2005-05-23 22:01:20 UTC
lon, please also specify the location (directory) where this script should go. 

Comment 6 Lon Hohberger 2005-05-23 23:00:14 UTC
I think it goes in /sbin as "fence_wti".

Please back up the existing one.

Comment 7 Lon Hohberger 2005-05-23 23:00:50 UTC
Changed to "enhancement" since it's documented as a currently unsupported feature.

Comment 10 Adam "mantis" Manthei 2005-05-26 15:35:17 UTC
in rhel3 now too

Comment 11 Lon Hohberger 2005-05-26 17:32:20 UTC
It should look something oddly like this for GFS 6.0:

nodes {
  foo {
    fence {
      power {
        wti1 {
          port = "1"
          option = "off"
        }
        wti1 {
          port = "5"
          option = "off"
        }
        wti1 {
          port = "1"
          option = "on"
        }
        wti1 {
          port = "5"
          option = "on"
        }
      }
    }
  }
}


Comment 12 Lon Hohberger 2005-05-26 17:34:13 UTC
See also:

http://www.redhat.com/docs/manuals/csgfs/admin-guide/s1-sf-nodes.html#FIG-SF-NODESAPCDUAL

It should work the same way as the APC, except you don't need a "switch=.."
parameter.

Comment 13 Lon Hohberger 2005-05-26 17:49:26 UTC
Note on power redundancy:

The WTI series switches (except for the TPS-2) have redundant power sources. 
Half of the ports are on rail A, and half are on rail B.  With an IPS-800/800CE
or NPS-115/230, ports 1-4 are on rail A and ports 5-8 are on rail B.

It's important to use one plug from each power rail when controlling a node with
multiple power supplies.  Failure to do so makes the power rail and power source
a single point of failure, which can otherwise be prevented.

Comment 14 Jim Parsons 2006-08-30 19:52:45 UTC
This was fixed by Adam a while back.


Note You need to log in before you can comment on or make changes to this bug.